Welcome, Guest

Author Topic: [RESOLVED] Can not see any text  (Read 5736 times)

Envite

  • **
  • Posts: 18
[RESOLVED] Can not see any text
« on: October 06, 2014, 01:06:37 PM »
Hi all

I do not know what happens, but in my Universe Sandbox 2 (downloaded today, Linux) I can not see any text.

« Last Edit: October 14, 2014, 03:31:20 PM by Envite »

Xriqxa

  • *****
  • Posts: 1441
  • 01000011 01101111 01101101 01101101 01110101 01101
Re: Can not see any text
« Reply #1 on: October 06, 2014, 11:36:50 PM »
Unfortunately, I cannot understand what you mean. Is there no UI or something...? A little more info and maybe even a screenshot would be a little more helpful :)

Envite

  • **
  • Posts: 18
Re: Can not see any text
« Reply #2 on: October 07, 2014, 04:31:53 AM »
I did attach a screenshot. There were a problem in the image server. That seems to be resolved now, so you should be able to see the image. I see the UI and the planets, but no text at all, so I can not change options.

Xriqxa

  • *****
  • Posts: 1441
  • 01000011 01101111 01101101 01101101 01110101 01101
Re: Can not see any text
« Reply #3 on: October 07, 2014, 05:27:17 AM »
Very odd. I'm sure a developer will be with you shortly.

Jar

  • Developer
  • *****
  • Posts: 689
    • Universe Sandbox
Re: Can not see any text
« Reply #4 on: October 10, 2014, 02:09:55 PM »
Could you attach your log file please?

On Linux, it is typically located here:
~/.config/unity3d/GiantArmy/UniverseSandbox/Player.log

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3243
    • Personal Site
Re: [INFO] Can not see any text
« Reply #5 on: October 10, 2014, 03:25:15 PM »
It might be worth verifying the download too...

Follow step 3 here:
http://universesandbox.com/forum/index.php/topic,13207.0.html

C7

  • Development Team
  • *****
  • Posts: 544
Re: [INFO] Can not see any text
« Reply #6 on: October 10, 2014, 06:11:13 PM »
Chances are, this is an issue due to a missing font, or invalid language / localization settings. What distro of Linux are you on? The log files would be useful as well, as Dan mentioned.

Try launching with the command line option LC_ALL=C or LC_LANG=C (if the previous option fails)

Envite

  • **
  • Posts: 18
Re: Can not see any text
« Reply #7 on: October 11, 2014, 03:02:35 AM »
Could you attach your log file please?

On Linux, it is typically located here:
~/.config/unity3d/GiantArmy/UniverseSandbox/Player.log

Hi Jar

Here it is (attached).

Just that it is not in ~/.config/unity3d/GiantArmy/UniverseSandbox/Player.log but ~/.config/unity3d/Giant Army/Universe Sandbox /Player.log (note three spaces and the two superscript).

Thanks

Envite

  • **
  • Posts: 18
Re: [INFO] Can not see any text
« Reply #8 on: October 11, 2014, 03:08:48 AM »
It might be worth verifying the download too...

Follow step 3 here:
http://universesandbox.com/forum/index.php/topic,13207.0.html

Hi Dan

Verified OK. Cleaned and re-downloaded it, and still the same no-text issue.

Thanks

Envite

  • **
  • Posts: 18
Re: [INFO] Can not see any text
« Reply #9 on: October 11, 2014, 03:10:39 AM »
Chances are, this is an issue due to a missing font, or invalid language / localization settings. What distro of Linux are you on? The log files would be useful as well, as Dan mentioned.

Try launching with the command line option LC_ALL=C or LC_LANG=C (if the previous option fails)

Hi C7.

This is a Debian GNU/Linux localized to spanish (UTF8). The log file is attached above.

I tried to launch steam with LC_ALL=C and launched in spanish as well, and then it did not connect to the server and aborted.

Thanks

C7

  • Development Team
  • *****
  • Posts: 544
Re: [INFO] Can not see any text
« Reply #10 on: October 11, 2014, 04:29:15 AM »
Hi, thanks for the log files, it is a language and localization issue. Your logs are using , in place of . during some of the parsing. You can change that at the operating system level if you like, however you should be able to override it for specific applications if you don't want to change the decimal format globally.

Though, to clarify, you need to specify the the LC_ALL=C option in the properties for Universe Sandbox . Not on the Steam executable itself. I'm not sure on Debian, but you may need to enter the launch option like this LC_ALL=C %command%

Here's a guide for setting the launch options for a game using Steam's library.

https://support.steampowered.com/kb_article.php?ref=1040-JWMT-2947

Alternatively, you should be able to launch the Universe Sandbox executable from the terminal while steam is running and specify LC_ALL=C that way.

I'll update the guide to have the correct paths you cited. Thank you following up!
« Last Edit: October 11, 2014, 04:39:38 AM by C7 »

Caldazar

  • ***
  • Posts: 21
Re: [INFO] Can not see any text
« Reply #11 on: October 11, 2014, 12:30:55 PM »
Code: [Select]
LC_ALL=C ./"Universe Sandbox.x86_64"doesn't work for me. I know it once did but since a while it doesn't do anything.
Still no menus or any text, still the error

Font XML does not exist: default

in the log(, which wasn't there the one time it worked)

Envite

  • **
  • Posts: 18
Re: [INFO] Can not see any text
« Reply #12 on: October 14, 2014, 03:12:15 AM »
Hi, thanks for the log files, it is a language and localization issue. Your logs are using , in place of . during some of the parsing. You can change that at the operating system level if you like, however you should be able to override it for specific applications if you don't want to change the decimal format globally.

No, I do not want to change it globally. I need these things is spanish for most other things.

Though, to clarify, you need to specify the the LC_ALL=C option in the properties for Universe Sandbox . Not on the Steam executable itself. I'm not sure on Debian, but you may need to enter the launch option like this LC_ALL=C %command%

I did this on a Terminal while Steam was running:

Code: [Select]
LC_ALL=C /home/envite/.steam/steam/SteamApps/common/Universe\ Sandbox\ 2/Universe\ Sandbox.x86_64
It lauched correctly but the issue continued: no text at all.

Here's a guide for setting the launch options for a game using Steam's library.

https://support.steampowered.com/kb_article.php?ref=1040-JWMT-2947

Alternatively, you should be able to launch the Universe Sandbox executable from the terminal while steam is running and specify LC_ALL=C that way.

About the launch options, this way seems to be for adding options that would be added to the command line at the end, but not suited for environment variables.

I'll update the guide to have the correct paths you cited. Thank you following up!

I have the feeling this is a great program, but I really can not test so.

Thanks

Noel

C7

  • Development Team
  • *****
  • Posts: 544
Re: [INFO] Can not see any text
« Reply #13 on: October 14, 2014, 03:22:44 AM »
We'll keep working on a solution to this so you can play the game. I'll look into the font issue next.

In your previous post the game was finally working for you Caldazar. Has it stopped working with the changes in Alpha 11.3?

Envite

  • **
  • Posts: 18
Re: [INFO] Can not see any text
« Reply #14 on: October 14, 2014, 03:45:19 AM »
More info:

a)
I checked (via /proc) the environment of the running executable of US2 and the LC_ALL option was not there, but a lot of Steam environment options not present in the shell were.

This means that launching US2 from the terminal with LC_ALL=C does not make it launch directly from there, but instead the executable somehow contacts the steam program, which detects that the launch has not been properly set up, and launches it anew from steam (effectively ignoring any LC_ALL or any other environment option you may set).

b)
I tried to create a wrapper in the place of the executable but it refused to launch.

Caldazar

  • ***
  • Posts: 21
Re: [INFO] Can not see any text
« Reply #15 on: October 14, 2014, 05:54:54 AM »
We'll keep working on a solution to this so you can play the game. I'll look into the font issue next.

In your previous post the game was finally working for you Caldazar. Has it stopped working with the changes in Alpha 11.3?

It started back then when I deleted Universe Sandbox_Data/Managed/System.Configuration.dll and so does it now.
But even pre Alpha 11.3 somehow the LC_ALL tweak stopped working.
This is odd as I can't think of anything that has changed since the one time we got the text working, other than updating Linux and my graphics stack.

With Alpha 11.3 the status is still the same:
- With System.Configuration.dll active, the program freezes, without it, it starts. With reduced resolution, without text (just some grey menu symbols ) and pretty much as a slide show. It's also easy to crash by playing with the menu, but it does start.

I concentrated on that success in that thread because I was aware what alpha means when I bought the game and well, one step after the other.




Xriqxa

  • *****
  • Posts: 1441
  • 01000011 01101111 01101101 01101101 01110101 01101
Re: [INFO] Can not see any text
« Reply #16 on: October 14, 2014, 07:17:38 AM »
Happened to me some time ago, restarted Ubox2 and it fixed itself. Obviously it's a different story with you :c

Caldazar

  • ***
  • Posts: 21
Re: [INFO] Can not see any text
« Reply #17 on: October 14, 2014, 01:56:46 PM »
Thanks @Envite and @C7, it's indeed Steam not caring about LC_ALL (anymore?).

Setting LANG globally to en_US or just for Steam, both works.

1. Shutdown Steam
2. Check /etc/locale.gen if
Code: [Select]
en_US.UTF-8 UTF-8is uncommented.

>>>
Only if it isn't:
Uncomment it and then run
Code: [Select]
locale-gen
<<<

Now you have two options:
Change the locale globally with
Code: [Select]
export LANG=en_US.UTF-8
If you don't want this, start steam with
Code: [Select]
env LANG=en_US.UTF-8 steam &
After that US2 can be launched normally and displays text.

You might also change your .desktop launcher file for US2 to exec
Code: [Select]
Exec=env LANG=en_US.UTF-8 steam steam://rungameid/<THE_ID>
« Last Edit: October 14, 2014, 02:05:34 PM by Caldazar »

Envite

  • **
  • Posts: 18
Re: [INFO] Can not see any text
« Reply #18 on: October 14, 2014, 03:22:20 PM »
Code: [Select]
export LC_ALL=C
export LANG=C
steam
worked for me. Thanks.

Strangely enough, Steam is still in spanish, but US2 is correctly running in english with text.

Issue is now resolved. Underlying cause (US2 not working properly on spanish system) is still to be resolved, but that can wait.

Now that I have tested it (a bit), it is an awesome program. You'll hear more from me.

Thanks again.

C7

  • Development Team
  • *****
  • Posts: 544
Re: [RESOLVED] Can not see any text
« Reply #19 on: October 14, 2014, 05:43:53 PM »
Thanks again Caldazar. I had suspected it was something wrong with the language settings again, but I wonder why Steam is suddenly not respecting the launch settings now. I wonder if it's our update, or the Steam client updated recently.

Steamworks will cause the program to relaunch if it's started outside of Steam. It's quite possible it's ignoring the launch commands at that point. Hmm, I'll go over the documentation and see if something has changed, I might need to file a bug report about that, or see if I can find a way of relaunching with the same settings it was originally launched with.

Caldazar

  • ***
  • Posts: 21
Re: [RESOLVED] Can not see any text
« Reply #20 on: October 15, 2014, 01:14:00 AM »
You and Envite are right here, my en_US route is overly complicated.
Just starting steam with LC_ALL=C works as well.
Steam just doesn't respect the settings for the US2 executable any more.