Welcome, Guest

Author Topic: Steam install bug  (Read 5116 times)

johnnyhero

  • *
  • Posts: 1
Steam install bug
« on: March 18, 2012, 08:02:04 PM »
I really want to like this game and this developer, but installing this game has become very frustrating.  I bought it on Steam, but every time I try to install, I get an error with "Microsoft Visual Studio 2010 x86".  It tells me "Fatal error during installation".  I have also tried to install these components separately through the "commonapps" folder in Steam as an administrator with no luck.  The most frustrating part of all of this is that I also downloaded the game using the button at the top of the forum and it works.  However it won't recognize that I have the Steam version.  I have tried uninstalling, verifying game cache, repairing, and downloading Visual Studio through Microsoft and none of them have worked. 

smjjames

  • *****
  • Posts: 1128
Re: Steam install bug
« Reply #1 on: March 18, 2012, 10:29:27 PM »
Did you accidentially download the non-steam version? Or maybe try downloading from steam instead?

Also this is for Ubox 2.

Bla

  • Global Moderator
  • *****
  • Posts: 1011
  • The stars died so you can live.
Re: Steam install bug
« Reply #2 on: March 19, 2012, 07:53:02 AM »
I think they are two seperate versions, at least updates ot the Steam and non-Steam versions seem to be released seperately.

Have you tried letting Steam download and install it?

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3243
    • Personal Site
Re: Steam install bug
« Reply #3 on: March 19, 2012, 11:14:13 PM »
That's strange... so when you install on Steam it gives you an error and won't ever just start the game?

While it doesn't help you now... I'm so looking forward to when we release the new update that won't rely on these dependencies that seem to cause people so many problems (to be released later this year as a free update).

Can you try uninstalling "Microsoft Visual Studio 2010..." in your list of install apps in the Control Panel?

mrmarleau

  • *
  • Posts: 2
Re: Steam install bug
« Reply #4 on: July 24, 2012, 06:38:29 AM »
I'm having a very similar issue, except my install just sits on "Installing: Microsoft VC Redist Package..." forever, I don't get an actual error.

I tried uninstalling Visual Studio 2010 with no change.

I also tried going to the /Universe Sandbox/Prerequisites folder and installing the vcredist files from there but that didn't change much. I can see the processes start up, but both hover at 1,476K memory usage and 0 CPU.

I'm running Win7 64 bit (yes I tried running as admin).

Any ideas?

mrmarleau

  • *
  • Posts: 2
Re: Steam install bug
« Reply #5 on: July 24, 2012, 06:50:21 AM »
Well now I feel silly. I was going over the"How to Solve Startup Problems" thread again and I stopped on the part where it recommends to restart your PC.

Steps like those never help when you think to try them first, but when don't do that before reaching out for help... it's always something like that.

Problem solved :P (for me at least, sorry to jump in this thread)

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3243
    • Personal Site
Re: Steam install bug
« Reply #6 on: July 27, 2012, 02:33:42 PM »
No worries. I'm sorry you had a problem at all. I expect the new version will solve most of these start up issues.