Welcome, Guest

Author Topic: [Steam] Universe Startup Problem (SOLVED)  (Read 7898 times)

crazierinzane

  • *
  • Posts: 5
[Steam] Universe Startup Problem (SOLVED)
« on: May 03, 2011, 07:06:09 AM »
The issue has been fixed

I am not sure what the problem was, but after several hours of trouble shooting a new recent problem that has nothing to do with Universe Sandbox (I'll get to it) and downloading several Windows updates (2 of which failed for some reason) I can now start it up and do whatever I want, no problem.


My more pressing issue, not associated with Universe Sandbox, is that I can't open System Properties, the Network sharing center (from the tray), Default Programs, Windows Updates, and probably more things. Nothing happens, I try to open them and it gives me the loading circle for a quarter of a second and then just nothing.

Also, some commands like "sfc /scannow" and "ipconfig" and most likely many more, are not working in the cmd box. I am the admin and owner of the computer, so there is no question there. Last thing I can think of is that it keeps trying to install 2 updates that keep failing according to the update log.


This happened after I ran a registry cleaner and short cuts cleaner, ect. So I am assuming that has to do with the problems.

Hours of Google has failed me...
So yeah, anyone who reads this, and happens to have any kind of idea as to what I should do, please post.



v Original Post v
----------------------------------------------------------

After I impulse bought this on Steam, I was very sad to find out that once I attempted to to launch it, it immediately froze gave an error message, which was quickly hidden under another error message.

Computer info:
Win 7 Possessional 64bit,
MSI N275GTX TwinFrozr OC GeForce GTX 275 896MB 448-bit GDDR3 PCI Express 2.0 x16 HDCP Ready SLI Support Video Card,
Processor   Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz, 2668 Mhz, 4 Core(s), 8 Logical Processor(s),

This is the error message on the bottom:

I can't click ok...because the program has stopped working.


This is the text of the error message:

"See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentException: Parameter is not valid.
   at System.Drawing.Image.get_FrameDimensionsList()
   at System.Drawing.ImageAnimator.CanAnimate(Image image)
   at System.Drawing.ImageAnimator.ImageInfo..ctor(Image image)
   at System.Drawing.ImageAnimator.Animate(Image image, EventHandler onFrameChangedHandler)
   at System.Windows.Forms.PictureBox.Animate(Boolean animate)
   at System.Windows.Forms.PictureBox.Animate()
   at System.Windows.Forms.PictureBox.OnVisibleChanged(EventArgs e)
   at System.Windows.Forms.Control.OnParentVisibleChanged(EventArgs e)
   at System.Windows.Forms.Control.OnVisibleChanged(EventArgs e)
   at System.Windows.Forms.ScrollableControl.OnVisibleChanged(EventArgs e)
   at System.Windows.Forms.Form.OnVisibleChanged(EventArgs e)
   at System.Windows.Forms.Control.WmShowWindow(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.Form.WmShowWindow(Message& m)
   at System.Windows.Forms.Form.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.225 (RTMGDR.030319-2200)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
Universe Sandbox
    Assembly Version: 2.1.1.900
    Win32 Version: 2.1.1.900
    CodeBase: file:///c:/program%20files%20(x86)/steam/steamapps/common/universe%20sandbox/Universe%20Sandbox.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
AutomaticUpdater
    Assembly Version: 2.6.11.2
    Win32 Version: 2.6.11.2
    CodeBase: file:///c:/program%20files%20(x86)/steam/steamapps/common/universe%20sandbox/AutomaticUpdater.DLL
----------------------------------------
2597e9f8-2eef-40c9-8752-607de42b12e1
    Assembly Version: 1.0.0.0
    Win32 Version: 2.1.1.900
    CodeBase: file:///c:/program%20files%20(x86)/steam/steamapps/common/universe%20sandbox/Universe%20Sandbox.exe
----------------------------------------
MTV3D65
    Assembly Version: 6.5.3602.42214
    Win32 Version:
    CodeBase: file:///c:/program%20files%20(x86)/steam/steamapps/common/universe%20sandbox/MTV3D65.DLL
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 10.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
Squid
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///c:/program%20files%20(x86)/steam/steamapps/common/universe%20sandbox/Squid.DLL
----------------------------------------
Microsoft.VisualC
    Assembly Version: 10.0.0.0
    Win32 Version: 10.00.30319.01
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualC/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualC.dll
----------------------------------------
WiimoteLib
    Assembly Version: 1.5.2.0
    Win32 Version: 1.5.2.0
    CodeBase: file:///c:/program%20files%20(x86)/steam/steamapps/common/universe%20sandbox/WiimoteLib.DLL
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

"



I'm not very program savvy (I should be seeing as I want to get into this field) so I'm not sure if there is a simple fix to this. Clicking continue just causes it to follow the usual "This program has stopped working, Debug?" Crashes.

So I'm not sure if the big update even went through Steam, but it still crashes the same way it did yesterday.
« Last Edit: May 03, 2011, 02:23:20 PM by crazierinzane »

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: [Steam] Universe Startup Problem (Parameter is not valid)
« Reply #1 on: May 03, 2011, 07:39:05 AM »
I'm sorry it's not working for you. I've never seen this error before.

Can you find the 3 log files that are here:
(My) Documents\Universe Sandbox\Logs
... and email them to me.

dan at universesandbox dot com

Make this your subject:
A generic error occurred in GDI+

And include a link to this post:
http://universesandbox.com/forum/index.php?action=post;topic=3490.0

That will help identify the problem so I can fix it in an upcoming build.

Dan
http://universesandbox.com/

crazierinzane

  • *
  • Posts: 5
Re: [Steam] Universe Startup Problem (Parameter is not valid)
« Reply #2 on: May 03, 2011, 07:55:19 AM »
Sent

crazierinzane

  • *
  • Posts: 5
Re: [Steam] Universe Startup Problem (Parameter is not valid)
« Reply #3 on: May 03, 2011, 10:58:44 AM »
This is probably a problem with my computer, not Universe.


Maybe a registry cleaner or something killed it for me, I'll try to fix it on my end.

NovaSilisko

  • ***
  • Posts: 25
Re: [Steam] Universe Startup Problem (Parameter is not valid)
« Reply #4 on: May 03, 2011, 12:42:56 PM »
How about we form a "completely mysterious and unique errors" club?

crazierinzane

  • *
  • Posts: 5
Re: [Steam] Universe Startup Problem (Parameter is not valid)
« Reply #5 on: May 03, 2011, 02:22:18 PM »
The issue has been fixed

I am not sure what the problem was, but after several hours of trouble shooting a new recent problem that has nothing to do with Universe Sandbox (I'll get to it) and downloading several Windows updates (2 of which failed for some reason) I can now start it up and do whatever I want, no problem.


My more pressing issue, not associated with Universe Sandbox, is that I can't open System Properties, the Network sharing center (from the tray), Default Programs, Windows Updates, and probably more things. Nothing happens, I try to open them and it gives me the loading circle for a quarter of a second and then just nothing.

Also, some commands like "sfc /scannow" and "ipconfig" and most likely many more, are not working in the cmd box. I am the admin and owner of the computer, so there is no question there. Last thing I can think of is that it keeps trying to install 2 updates that keep failing according to the update log.


This happened after I ran a registry cleaner and short cuts cleaner, ect. So I am assuming that has to do with the problems.

Hours of Google has failed me...
So yeah, anyone who reads this, and happens to have any kind of idea as to what I should do, please post.

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: [Steam] Universe Startup Problem (SOLVED)
« Reply #6 on: May 03, 2011, 02:55:34 PM »
Great to hear.

Can you do a system restore to the point before the 'cleaning'?

Or do a repair install of windows?

Those are my two quick thoughts.

crazierinzane

  • *
  • Posts: 5
Re: [Steam] Universe Startup Problem (SOLVED)
« Reply #7 on: May 03, 2011, 03:15:23 PM »
Im flailing myself for not creating any backups, or restore points.


Shit

Shhiitttt

SSSSHHIIIIIITTTTT

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: [Steam] Universe Startup Problem (SOLVED)
« Reply #8 on: May 04, 2011, 04:24:29 PM »
Try creating a new Windows user from the control panel, log out, and then log into the new user account. And see if you're still having problems.

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: [Steam] Universe Startup Problem (SOLVED)
« Reply #9 on: May 05, 2011, 09:10:00 PM »
Moved the rest of the thread into the thread with the same error message here:
http://universesandbox.com/forum/index.php/topic,3378.msg33836.html#msg33836