Welcome, Guest

Author Topic: 2 FPS  (Read 4931 times)

UniversalSandvich

  • **
  • Posts: 12
  • hi u ok?
2 FPS
« on: October 13, 2014, 05:07:49 PM »
I just bought the game and it is as laggy as heck and setting the quality to low doesn't even help
« Last Edit: October 13, 2014, 05:43:43 PM by UniversalSandvich »

UniversalSandvich

  • **
  • Posts: 12
  • hi u ok?
Re: 2 FPS
« Reply #1 on: October 13, 2014, 05:26:00 PM »
I just installed OpenCL too. No fix. It always drops down from 30 to 2.70 and then rises to 3 then back to to 2.70

C7

  • Development Team
  • *****
  • Posts: 544
Re: 2 FPS
« Reply #2 on: October 14, 2014, 03:14:33 AM »
If you could, please run the performance test built into the game, and send a feedback email with attention to C7 as the subject. It will provide me with a lot more detail, as well as a breakdown of the compute performance for all your devices.

Hopefully we can find out where the problem is.

Thanks!

Caldazar

  • ***
  • Posts: 21
Re: 2 FPS
« Reply #3 on: October 14, 2014, 02:58:27 PM »
Same here with Arch Linux and also an AMD graphics card.
Sent an e-mail from ingame.

C7

  • Development Team
  • *****
  • Posts: 544
Re: 2 FPS
« Reply #4 on: October 14, 2014, 05:38:03 PM »
Thanks, we're working on some overhauls with the physics engine right now that will hopefully address these problems. I'm just trying to collect as much data as possible right now, so we can find out exactly what areas we're getting bottle necked are.

UniversalSandvich

  • **
  • Posts: 12
  • hi u ok?
Re: 2 FPS
« Reply #5 on: October 14, 2014, 07:17:26 PM »
Thank you.

Caldazar

  • ***
  • Posts: 21
Re: 2 FPS
« Reply #6 on: October 15, 2014, 01:09:21 AM »
After testing different scenarios, I like to add that this seems to be rather a gradual problem with computing object properties, not so much with graphics.

Heavy simulations like "solar system", "saturn rings" and "colliding galaxies"  start fine at ~55fps but go down to 3fps after a few seconds.
Other more lightweight sims run fine at 55fps although the objects tend to "jump" there too.

As with UniversalSandvich, graphics settings don't seem to have any effect.

Caldazar

  • ***
  • Posts: 21
Re: 2 FPS
« Reply #7 on: October 17, 2014, 12:51:31 AM »
@All who have this problem:
Please test in the default simulation (solar system) whether deleting all particles/dust solves the issue for you as well.
(sim: Settings => Simulation => Actions => Delete All Particles / Dust)

On my machine it reduces "Physics Advance" from ~360ms to ~5 ms and by that the building of an "entire frame" from ~390ms to ~35ms. (Those informations can be watched in the profiler, bottom right corner).

I still haven't tested a lot of other stuff like deleting fragments or stuff. Feel free to play around.
« Last Edit: October 17, 2014, 02:31:32 AM by Caldazar »

Electrodynamix

  • *****
  • Posts: 77
  • Australian Alpha Tester and Astronomer
Re: 2 FPS
« Reply #8 on: October 30, 2014, 01:09:15 AM »
Dont you need OpenGL, not OpenCL?

C7

  • Development Team
  • *****
  • Posts: 544
Re: 2 FPS
« Reply #9 on: November 05, 2014, 04:37:00 AM »
Just to clarify, OpenGL is used to render the game on Mac and Linux platforms. On Windows, it uses DirectX by default.

OpenCL however, is used for computing things like gravity. If your graphics card or processor supports it, we can use OpenCL to get a huge performance boost. While it's not necessary, it's certainly recommended.

BrandCollision

  • *****
  • Posts: 95
  • I am a major fanboy of space games :)
Re: 2 FPS
« Reply #10 on: November 08, 2014, 11:11:19 AM »
I had a similar problem with Minecraft - that is, until i upgraded to a gaming computer, try doing that, yes, i know they are expensive, but its worth it, and if this doesn't fix your problem, i don't know what will, also, i have had US2 only whilst on this computer, and i don't get much FPS lag, only really lag when the collisions happen and accuracy thing

The reason computers are expensive is because they are good, if you got a rather cheap computer, its probably pretty bad, no offence

« Last Edit: November 08, 2014, 11:18:16 AM by BrandCollision »

MattyNoNeck

  • *
  • Posts: 2
Re: 2 FPS
« Reply #11 on: November 18, 2014, 07:44:04 AM »
I just bought and downloaded US2 today and to my dismay, the FPS just DROPPED as soon as I started going through the tutorial and I ended up her.  It would seem that Caldazar's suggestion, however, of eliminating dust and debris did the trick.

I hope this helps the devs nail down a fix.  Anything else, I can do to help, I'll be glad to do

C7

  • Development Team
  • *****
  • Posts: 544
Re: 2 FPS
« Reply #12 on: November 18, 2014, 08:13:10 AM »
We're working on some overhauls for the particle systems in the next Alpha, that should improve the situation a bit.

We've also got a major Physics overhaul that's been underway for a while now, and will hopefully be done soon. Due to the nature of the Physics engine's complexity, it's not something that we can integrate in steps like other features.

Either way, we're still working hard on it, and getting the game running smoothly is a priority for us.

MattyNoNeck

  • *
  • Posts: 2
Re: 2 FPS
« Reply #13 on: November 18, 2014, 08:18:46 AM »
Great to hear and thanks for the quick response!

Running a performance test now and will send the results along.  Just to give you a heads up, though, the first two went ok (slowed down a little bit with the insane amount of moons but it was ok).  I have now been stuck on the galaxy collision for probably 15+ minutes with less than 1 FPS.  Hope this helps.