Welcome, Guest

Author Topic: [Support] Slow FPS  (Read 2412 times)

Quizer9O8

  • *****
  • Posts: 65
[Support] Slow FPS
« on: September 24, 2014, 11:34:39 AM »
Whenever starting US2 it'll always go to the solar system but when its there, it stutters at 2 - 5,25 fps.
Is there a way to increase the FPS in a config file or IS (In simulator)

Unnamed25

  • *****
  • Posts: 159
  • o hai
Re: Slow FPS
« Reply #1 on: September 24, 2014, 02:45:25 PM »
Oh god why
How to get more FPS:
Stop using a potato to simulate the solar system
EDIT: ohhhhh
Yeah for some reason the solar system is laggy for me too now on alpha 11.2

C7

  • Development Team
  • *****
  • Posts: 544
Re: Slow FPS
« Reply #2 on: September 25, 2014, 02:49:55 AM »
We'd need to see your system specs and perhaps a performance test to see exactly where the slowdown is at. We're in the middle of some transitions with the physics and performance optimization. It might get a little worse until it gets better.

Quizer9O8

  • *****
  • Posts: 65
Re: Slow FPS
« Reply #3 on: September 25, 2014, 11:56:43 AM »
Oh god why
How to get more FPS:
Stop using a potato to simulate the solar system
EDIT: ohhhhh
Yeah for some reason the solar system is laggy for me too now on alpha 11.2

Oh wow, you show no sympathy and being rude from the beginning.
I do understand why people will give you a taste of your own medicine but 10 times more furious than I do.
And why this, because I ask a way to increase my FPS? you think i'm talking nonsense oh please look at the posts I recently made before judging someone like me.

EDIT: EDIT won't work buddy, this goes right on the topic  :-X

But getting back at the topic

We'd need to see your system specs and perhaps a performance test to see exactly where the slowdown is at. We're in the middle of some transitions with the physics and performance optimization. It might get a little worse until it gets better.

It seems like the Ring particles are causing the fps to drop down to almost 0 but when they're all removed you can see the different right ahead.






How are the particles being rendered?

Feldruam

  • ****
  • Posts: 50
  • TVP Resource Based Economy
Re: Slow FPS
« Reply #4 on: September 26, 2014, 03:10:51 AM »
I have low fps, then crash to desktop ever since update 11, it could be a bug with the collision effects. Something's not optimized, it'll slow down whenever I open the collision test or create a collision then it'll just stop and crash.

C7

  • Development Team
  • *****
  • Posts: 544
Re: Slow FPS
« Reply #5 on: September 26, 2014, 11:17:34 AM »
It would be really helpful to have log files from both of you, as well.

Can you please run the performance test in game, and use the built in feeback that happens afterwards to send us the test results? As well, can you please add ATTEN : C7 (slowdown) to the comments section of that feedback?

I want to help you both, but at this point I simply don't have enough information to know where to focus my efforts.

I'm going to move this topic over the bug / support section as well so I can keep an eye on it and follow up with you.

The particle renderer itself isn't doing anything fancy, it's using Unity's Shuriken Particle system. However we are simulating the particles as physical, and gravity influenced objects. The rendering of the particles themselves should be trivial compared to them being integrated into the gravity simulation. If that's not the case, then there's a fairly serious bug. So I'll look into that for now.

Additionally, can you test running the game with AA (anti-aliasing) in the graphics option set to off?

im4space

  • Global Moderator
  • *****
  • Posts: 87
Re: [Support] Slow FPS
« Reply #6 on: September 27, 2014, 06:29:34 AM »
I am having a slow down on the start up screen too. With version 11.2 I get 3.0 fps. I turned off AA and it didn't make any difference, it was still 3.0 fps. I am using the 32 bit version.

With version 10.1, I got 9.0 fps.

DrSauce

  • ***
  • Posts: 22
Re: [Support] Slow FPS
« Reply #7 on: September 30, 2014, 09:33:11 AM »
Can't use the video card to compute, the gravity doesn't works with it, I have to go with the cpu and it is painfully slow.

UniversalSandvich

  • **
  • Posts: 12
  • hi u ok?
Re: [Support] Slow FPS
« Reply #8 on: October 13, 2014, 05:12:10 PM »
SAME HERE