Welcome, Guest

Author Topic: [Support/Bug?] Saving Issues  (Read 2524 times)

MrZxs

  • *
  • Posts: 4
[Support/Bug?] Saving Issues
« on: August 26, 2015, 06:29:58 PM »
I'm not to sure if this is a bug or not but thought I would check anyway;

When I change a magnetic field of a planet it doesn't carry over if I save and then load the save.

 If I set a star off of realistic then save and load the save the star is changed back to realistic.

Also great job on the game so far!

Darvince

  • *****
  • Posts: 1839
  • 差不多
Re: [Support/Bug?] Saving Issues
« Reply #1 on: August 28, 2015, 10:24:40 PM »
As far as I know (not part of the Giant Army team), the saving function doesn't cover all features of bodies yet. This was a big issue for a while in the old Universe Sandbox some years ago, as many features didn't save. Is this in US² or US2?

MrZxs

  • *
  • Posts: 4
Re: [Support/Bug?] Saving Issues
« Reply #2 on: August 29, 2015, 01:11:40 PM »
US²

C7

  • Development Team
  • *****
  • Posts: 544
Re: [Support/Bug?] Saving Issues
« Reply #3 on: September 02, 2015, 12:24:32 AM »
We're still working on the save system, there's a few gaps in what it supports. I'll add this to the list, so we can address it in the future.

Sesquitone

  • *
  • Posts: 3
Re: [Support/Bug?] Saving Issues
« Reply #4 on: September 17, 2015, 10:19:52 PM »
I wanted to add a few items in a similar line of thought (also US2), with a focus on aspects of planets.
  • The radius tuning factor is always reset to 1, regardless if simulate radius is on or off when saving (it resets to on upon loading anyway). For me it typically reconciles this by adjusting the radius based on the composition density, but in one case I believe it compromised by adjusting both the mass and radius (I have not reproduced this one instance, though).
  • Infrared Emissivity stays put for planets with no atmosphere, but resets to 1 for those with even the slightest of one.
  • Temperature - Sometimes the temperature stays at the same saved value, sometimes it autosets to an equilibrium value, sometimes it sets near 0K, and once (again, I haven't reproduced it) it falls onto other unstable temperatures that I can't infer why. I have not delved into more detail to find out influencing factors.
  • A very minor point, but I noticed some attributes like radius have some "wiggle room" when saving, like it doesn't preserve all of the significant figures shown. I don't think it affects the overall quality, but I wanted to point it out in case it signified something more important.
Also, a big thank you to the developers for the hard work. Being relatively new to this program, I'm constantly amazed at how functional and beautiful it is in its current state. Keep up the good work!