Welcome, Guest

Author Topic: [BUG] Dispense tool causes simulation to freeze.  (Read 1197 times)

Deadpangod3

  • ****
  • Posts: 35
[BUG] Dispense tool causes simulation to freeze.
« on: February 08, 2015, 12:28:28 PM »
using the dispense tool to add Hydrogen to a gas giant causes the simulation to freeze, but not the program itself, you are still able to move the camera around and click on things, it happens the moment one of the particles hits the planet it freezes, and the only way to fix is to start a new simulation, i would include a video but its very simple and quick to recreate, just place a gas giant and use the dispenser tool to shoot hydrogen at it, i havnt tested it with other materials or planets however.

picture of the simulation in its frozen state:

C7

  • Development Team
  • *****
  • Posts: 544
Re: [BUG] Dispense tool causes simulation to freeze.
« Reply #1 on: February 08, 2015, 12:42:19 PM »
Can you try to use the dispenser tool and then send us your logs? It would help us narrow down the issue.

To do this, start Universe Sandbox up, try to load recreate your issue, after it fails. Click on the feedback icon (little star on the right). You can put in your email if you'd like us to use that to contact you. Put Atten: C7 Dispense Tool bug in the comments section, and make sure the send log option is checked.

Either that, or you can attach the log file to this forum thread, as you've done with the image.

Thanks!

Deadpangod3

  • ****
  • Posts: 35
Re: [BUG] Dispense tool causes simulation to freeze.
« Reply #2 on: February 08, 2015, 03:43:39 PM »
okay, sent it, i loaded up Universe Sandbox 2 again to recreate it with the same gas giant as before, but aparently earlier i had alot more stars in the list, even a couple small gas giants (or brown dwarfs) in the list too, like 51 Pegasi and alot of others, which were gone this time i loaded it up, and it was working fine for a bit when i tried using the dispenser tool, and i got it to happen again after setting the particle mass to about 5 earth masses, the particle mass was also high for the gas giants when i first had the bug, so i think it may be related to that, but im no programmer so i cant say for sure, just thought mentioning that might help.  :)