Welcome, Guest

Author Topic: Resource Usage Inefficiency  (Read 1653 times)

rilvin2

  • *
  • Posts: 1
Resource Usage Inefficiency
« on: September 16, 2014, 04:07:29 PM »
I'm not sure if this just a problem that I'm having or not, but it seems to me that the current version of Universe Sandbox 2 is very inefficient in its usage of CPU and GPU. No matter what I am doing in-game, the program is constantly using more than 40% of my available CPU (quad-core). Despite this massive consumption of resources, I am unable to run the basic Solar system simulation (low quality settings) at any higher than 7 fps. Even during collisions between relatively small objects (eg. Pluto & Ceres), I get terrible frame-rate. Also, however I am not as surprised by this, when I try to do anything with galaxies, my game crashes and I have to restart. I doubt that this is a hardware related problem, as I am able to run other very CPU intensive games at their highest setting without incident.

C7

  • Development Team
  • *****
  • Posts: 544
Re: Resource Usage Inefficiency
« Reply #1 on: September 16, 2014, 06:24:43 PM »
If you don't mind, run a performance test and send us the logs as well. You can put attention C7 in the comments, and I'll check to see why you're having issues, and where the slowdown is coming from.

Plutonium

  • *****
  • Posts: 152
Re: Resource Usage Inefficiency
« Reply #2 on: September 21, 2014, 12:49:03 AM »
I have similar problem but not to that extent. In most of the cases I see up to 2.5 times fps drop compared to alpha 10.

Earth & many moons scenario- FPS goes from 57 down to 20, the CPU usage stays under 30%.
Tried running on Low settings and decreased accuracy to 0%- no noticeable difference.