Welcome, Guest

Author Topic: [BUG] Broken Orbits & Controls  (Read 1561 times)

Godofpie

  • *
  • Posts: 2
[BUG] Broken Orbits & Controls
« on: September 08, 2014, 11:08:26 PM »
So I was trying to make a custom solar system when I came across a bug.
After I made Earth orbit around the Sun, everything seemed to be OK, but after I tried to add a Moon to the Earth, that's where things got messy



[ABOVE] It's a bit hard to see, but in the background there is Ganymede, which I tried to make orbit Earth. The strange thing is, the trails of where Ganymede should be are still orbiting Earth, yet the actual moon itself is far away.

Then there was the second bug, which happened just after that happened (I've had this one before, but never made a bug report). After this, most of my controls locked. I couldn't disable UI, pause time, add or select planets.

C7

  • Development Team
  • *****
  • Posts: 544
Re: [BUG] Broken Orbits & Controls
« Reply #1 on: September 09, 2014, 08:42:36 AM »
Sounds like something is encountering an error. Possibly a null reference or another exception. When that happens, can you capture your logs and send it to us? We need to catch it in the act to figure out what happened.

Since the UI crashed, you may need to exit the game and manually grab the log files, instead of using the built in report feature.

There's a guide on how to get your log files here.

http://universesandbox.com/forum/index.php/topic,12458.0.html