Welcome, Guest

Author Topic: [INFO] Planet and moon doesnt collide.  (Read 2215 times)

jbrown11

  • ****
  • Posts: 30
  • UK alpha tester. (i bought it)
[INFO] Planet and moon doesnt collide.
« on: September 03, 2014, 08:43:34 AM »
Well i went on ubox2 and i added the earth and a random Moon, i put the moon into a unstable orbit around earth and the moon kept going around and around when it  practically went through the earth and kept orbiting.
Anyway, i did do the feedback button thing.
If this happens again i will upload more pics of it.

Image(s) Below.
i think this is the log file thingy.
 
« Last Edit: September 08, 2014, 10:50:44 AM by jbrown11 »

C7

  • Development Team
  • *****
  • Posts: 544
Re: {BUG} Planet and moon doesnt collide.
« Reply #1 on: September 07, 2014, 04:12:26 PM »
Please post your error logs, so we can find out what's failing. You're not getting any special FX or other indicators that the impact has occurred. You can find a guide on how to post your error logs in the topic I've linked below.

http://universesandbox.com/forum/index.php/topic,12458.0.html


Electrodynamix

  • *****
  • Posts: 77
  • Australian Alpha Tester and Astronomer
Re: [INFO] Planet and moon doesnt collide.
« Reply #2 on: September 08, 2014, 04:46:07 PM »
This happens to me too.  If I create a new object with an orbit below the planets surface, it occasionally will not collide/merge.  This was a very old bug, I was pretty sure it was fixed in Alpha 10 or 10.1.

jbrown11

  • ****
  • Posts: 30
  • UK alpha tester. (i bought it)
Re: [INFO] Planet and moon doesnt collide.
« Reply #3 on: September 09, 2014, 08:23:18 AM »
This happens to me too.  If I create a new object with an orbit below the planets surface, it occasionally will not collide/merge.  This was a very old bug, I was pretty sure it was fixed in Alpha 10 or 10.1.



Yeah its not bad. its just abit annoying but since it is a alpha,  its ok to be buggy.
could you upload your log thing since its happen to me and you, the team will more likely fix it.
Anyway am trying to recreate the bug/problem. ;)

C7

  • Development Team
  • *****
  • Posts: 544
Re: [INFO] Planet and moon doesnt collide.
« Reply #4 on: September 09, 2014, 08:29:12 AM »
Ah, is this only happening if you place the bodies in orbit inside of eachother? It should automatically destroy, but perhaps you've found a case where that doesn't happen as it should.

jbrown11

  • ****
  • Posts: 30
  • UK alpha tester. (i bought it)
Re: [INFO] Planet and moon doesnt collide.
« Reply #5 on: September 10, 2014, 09:12:14 AM »
Ah, is this only happening if you place the bodies in orbit inside of eachother? It should automatically destroy, but perhaps you've found a case where that doesn't happen as it should.

 I did put a random moon in a really close(but not inside each other though. ) orbit, but other planets and moons should collide,  if i put them in the same orbit as the random moon.
Am trying to repeat the bug/issue so i have more evidence.