Welcome, Guest

Author Topic: [FIXED] Complete GUI crash (no crashlog, and had to terminate via task manager)  (Read 1425 times)

smjjames

  • *****
  • Posts: 1128
I was playing around with the Collapsing Momentum test when I decided to turn the icons on, but the instant I selected the show icons button, the GUI disappeared completely, not even the exit confirmation showed up when I clicked the X to close. Had to terminate via task manager.

Fakeedit: I forgot that opening Ubox up again erases the previous log, whoops. I'll post when I hit the bug again. Might have had something to do with there being lots of fragments.

Suggestion to the devs: Maybe have the logs cache themselves instead of erasing completely every time a new session is started? Might be confusing if there are many logs, but just a thought.

Edit: Reproduced the bug with even fewer fragments. I'll test with other simulations as there are a load of errors in this one.

Edit2: Oop, accidentially detached the previous output log, but here's the second one. The first one in the attatchment list is me testing with the Solar System-all planets all moons sim, the second is the same sim, but me turning off trails first. The errors are the same as the origional one which I had posted but accidentially detached.
« Last Edit: August 29, 2014, 06:46:20 AM by smjjames »

Chris

  • Developer
  • *****
  • Posts: 108
Re: Complete GUI crash (no crashlog, and had to terminate via task manager)
« Reply #1 on: August 25, 2014, 09:59:34 AM »
Fixed in internal build.
Thanks for reporting.

smjjames

  • *****
  • Posts: 1128
Fixed, as you said.