Welcome, Guest

Author Topic: How do you turn off the multiple projection lines when you select a body?  (Read 7453 times)

smjjames

  • *****
  • Posts: 1128
I'm talking about when you select a body that has gravitationally affected the paths of more than one body because it lags US extremely badly when there are LOTS of bodies connected to the one you've just selected.
« Last Edit: November 04, 2011, 12:01:37 PM by smjjames »

FiahOwl

  • *****
  • Posts: 1234
  • This is, to give a dog and in recompense desire my dog again.
Re: How do you turn off the multiple prediction lines when you select a body?
« Reply #1 on: November 04, 2011, 11:37:37 AM »
I'm talking about when you select a body that has gravitationally affected the paths of more than one body because it lags US extremely badly when there are LOTS of bodies connected to the one you've just selected.

...Pause the simulation to get rid of the Lag?

smjjames

  • *****
  • Posts: 1128
Re: How do you turn off the multiple prediction lines when you select a body?
« Reply #2 on: November 04, 2011, 11:48:21 AM »
Still doesn't get rid of the prediction lines from dozens or more bodies trying to orbit the one I just selected.

vh

  • formerly mudkipz
  • *****
  • Posts: 1138
  • "giving heat meaning"
Re: How do you turn off the multiple prediction lines when you select a body?
« Reply #3 on: November 04, 2011, 11:49:35 AM »
try turning off the projected path option.
there should be one. I'll go check right now.

Also it can lag even when simulation is paused. Every try a galaxy collision at 25x multiplier? :D

smjjames

  • *****
  • Posts: 1128
Re: How do you turn off the multiple prediction lines when you select a body?
« Reply #4 on: November 04, 2011, 11:51:34 AM »
That option IS off. At least the one in the options tab.

vh

  • formerly mudkipz
  • *****
  • Posts: 1138
  • "giving heat meaning"
Re: How do you turn off the multiple prediction lines when you select a body?
« Reply #5 on: November 04, 2011, 11:55:14 AM »
relation lines?

a screenshot would be nice. i can't get an idea of what you mean,

FiahOwl

  • *****
  • Posts: 1234
  • This is, to give a dog and in recompense desire my dog again.
Re: How do you turn off the multiple prediction lines when you select a body?
« Reply #6 on: November 04, 2011, 12:00:26 PM »
relation lines?

a screenshot would be nice. i can't get an idea of what you mean,

start universe sandbox and go into our solar system simulation, click on the sun.

smjjames

  • *****
  • Posts: 1128
Re: How do you turn off the multiple projection lines when you select a body?
« Reply #7 on: November 04, 2011, 12:01:17 PM »
I should have said projection paths, my mistake. But yea, it's like when you select the projected paths box except it's when you select a body, say Jupiter and you have the whole mess of projection lines. It doesn't always appear when you select a body at first though.

@Fiah: I probably confused him by saying prediction rather than projection lines.

vh

  • formerly mudkipz
  • *****
  • Posts: 1138
  • "giving heat meaning"
Re: How do you turn off the multiple projection lines when you select a body?
« Reply #8 on: November 04, 2011, 12:05:36 PM »
strange, it doesn't happen for me.
You said it doesn't always appear. When does it appear and after doing what? If you restart the sim does it go away? the program?

FiahOwl

  • *****
  • Posts: 1234
  • This is, to give a dog and in recompense desire my dog again.
Re: How do you turn off the multiple projection lines when you select a body?
« Reply #9 on: November 04, 2011, 12:09:56 PM »
strange, it doesn't happen for me.
You said it doesn't always appear. When does it appear and after doing what? If you restart the sim does it go away? the program?

Its a feature.

vh

  • formerly mudkipz
  • *****
  • Posts: 1138
  • "giving heat meaning"
Re: How do you turn off the multiple projection lines when you select a body?
« Reply #10 on: November 04, 2011, 12:12:37 PM »
"A distinguishing characteristic of a software item"

whatever is happening to him is not happening to me.

FiahOwl

  • *****
  • Posts: 1234
  • This is, to give a dog and in recompense desire my dog again.
Re: How do you turn off the multiple projection lines when you select a body?
« Reply #11 on: November 04, 2011, 12:14:28 PM »
"A distinguishing characteristic of a software item"

whatever is happening to him is not happening to me.


It happens to me.

...If it doesn't happen to you, then your universe sandbox copy is broken/outdated.

smjjames

  • *****
  • Posts: 1128
Re: How do you turn off the multiple projection lines when you select a body?
« Reply #12 on: November 04, 2011, 12:15:14 PM »
Okay, place a star (or other massive object), spam alot of bodies that orbit it and wait a bit. As I said, it doesn't always appear on the first click.

smjjames

  • *****
  • Posts: 1128
Re: How do you turn off the multiple projection lines when you select a body?
« Reply #13 on: November 10, 2011, 10:16:33 AM »
For those wanting a screenshot, here ya go.



If need be, I can make a video showing the lag :P

vh

  • formerly mudkipz
  • *****
  • Posts: 1138
  • "giving heat meaning"
Re: How do you turn off the multiple projection lines when you select a body?
« Reply #14 on: December 21, 2011, 06:09:44 PM »
ah-ha! found what went wrong (i think)

when you use the arrows on the value-boxes, like changing the mass, diameter, or whtever else, the projection lines come up. They dissapear when you deselect, but come back when you select. to get rid of, single click the text inside any of the box.

smjjames

  • *****
  • Posts: 1128
Re: How do you turn off the multiple projection lines when you select a body?
« Reply #15 on: December 21, 2011, 06:14:44 PM »
The problem is that the extreme lag makes it very hard to do that because the lag hits the instant I select a body which has lots of orbiting stuff.

I just switch the accuracy to Euler which at least stops the crazy projection shifting every microsecond and thus, stops the lag.

vh

  • formerly mudkipz
  • *****
  • Posts: 1138
  • "giving heat meaning"
Re: How do you turn off the multiple projection lines when you select a body?
« Reply #16 on: December 21, 2011, 06:16:22 PM »
try avoiding the arrow completely then. Use the number value and enter your own.

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3243
    • Personal Site
Re: How do you turn off the multiple projection lines when you select a body?
« Reply #17 on: December 21, 2011, 06:25:47 PM »
In 2.1.5, when moving a body, you can hold down Shift to disable projected paths.

vh

  • formerly mudkipz
  • *****
  • Posts: 1138
  • "giving heat meaning"
Re: How do you turn off the multiple projection lines when you select a body?
« Reply #18 on: December 21, 2011, 06:29:07 PM »
will and can there be a control that disables projected paths when hovering over an object? especially when working with objects that are touching each other while bounce mode is on, the paths get jittery and annoying.

smjjames

  • *****
  • Posts: 1128
Re: How do you turn off the multiple projection lines when you select a body?
« Reply #19 on: December 21, 2011, 06:32:07 PM »
try avoiding the arrow completely then. Use the number value and enter your own.

It usually starts the instant I select a body, before I even touch the number values.

In 2.1.5, when moving a body, you can hold down Shift to disable projected paths.

Will that work when you have a body selected?

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3243
    • Personal Site
Re: How do you turn off the multiple projection lines when you select a body?
« Reply #20 on: December 21, 2011, 07:32:39 PM »
It only works for drawing the projected paths of child bodies of whatever object you're moving (like the Sun).