Welcome, Guest

Author Topic: i cant play,HELP ME!  (Read 5415 times)

zionn10BE

  • *
  • Posts: 3
  • THIS IS SPARTAAAAAA!!!!!!!!!!!!!!
i cant play,HELP ME!
« on: September 25, 2010, 12:45:30 AM »
dear poeple,

i just found this awesome sandbox
so i wanna try the trial,
i downloaded it,installed it and than if i start up,this becomes:
'unable to find a version of the runtime to run this application'

can someone help me?

zionn10BE

(sorry for my english)

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: i cant play,HELP ME!
« Reply #1 on: September 25, 2010, 01:03:36 PM »
Download and install the latest version of .NET:

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=9cfb2d51-5ff4-4491-b0e5-b386f32c0992&displaylang=en

I suspect that will fix your problem. Please reply here to let us know what happens either way (both if it works or if it doesn't).

(and no worries about your English... it's easily better than my Dutch, French, or German)

rcrcrean13

  • **
  • Posts: 10
Re: i cant play,HELP ME!
« Reply #2 on: November 17, 2010, 03:56:21 PM »
I have this same problem...and I have both the directX and .NET versions needed to run the game...Also have Windows XP, so I have the correct operating system...I'm guessing maybe I need an older or different version or .NET in order for it to work properly, but i didn't find anything saying i needed anything else besides .NET framework 4 Web installer. I installed it directly from the website your link brings you to when you click it Dan.

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: i cant play,HELP ME!
« Reply #3 on: November 17, 2010, 05:31:58 PM »
I just recently realized that .NET 4 doesn't include the older versions of .NET required by Universe Sandbox.

Here's a link to the web installer for the older version of .NET that Universe Sandbox requires:
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=ab99342f-5d1a-413d-8319-81da479ab0d7&displaylang=en



More info

The older versions of .NET included all subsequent versions. Turns out .NET 4 doesn't include these earlier versions to keep the download smaller (and Windows 7 ships with .NET 1, 2, 3, & 3.5 - Windows XP doesn't include any version of .NET).

I just fixed this on the FAQ and download pages. I'm sorry I asked you to install the wrong version (however future version of Universe Sandbox will require .NET 4 and the next update will ask you to update if you don't already have .NET 4 installed).
« Last Edit: November 17, 2010, 05:56:08 PM by Dan Dixon »

rcrcrean13

  • **
  • Posts: 10
Re: i cant play,HELP ME!
« Reply #4 on: November 17, 2010, 06:12:49 PM »
so...what versions specifically will i need for the current version of US?

and... the next version will ONLY require .NET 4, or still require the previous ones? And if so, could you say which versions specifically I might need for future versions?

Thanks so much man :).
« Last Edit: November 17, 2010, 06:38:31 PM by rcrcrean13 »

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: i cant play,HELP ME!
« Reply #5 on: November 18, 2010, 03:41:42 PM »
You're going to need both .NET 2 and .NET 4 installed in order to use version 2.1 of Universe Sandbox.

(However, the next release of Universe Sandbox will be 2.0.14 and will include changes in preparation for the 2.1 release.)

Note that installing .NET 3.5 also installs .NET 2. Installing .NET 4 only installs .NET 4.



A distant future version (sometime after 2.1 is released) may only require .NET 4, but I'm not sure about that yet, it depends on getting new versions of the many support libraries that Universe Sandbox uses compiled against .NET 4. The reason that version 2.1 will require both versions of .NET is because some of the libraries will still require .NET 2 while the main program will require .NET 4.
« Last Edit: November 18, 2010, 06:16:54 PM by Dan Dixon »