Welcome, Guest

Author Topic: Rings Don't Want to be Awesome  (Read 4670 times)

Bla

  • Global Moderator
  • *****
  • Posts: 1013
  • The stars died so you can live.
Rings Don't Want to be Awesome
« on: September 21, 2010, 10:00:39 AM »
I've found a bug. In the new version (I don't know for how long it has lasted, but this is in 2.0.11), when I try to create awesome rings, the program just stops responding for a while and doesn't add any rings. I did this:

Opened the system 'Earth and moon' with shadows on dust and create collission lights enabled. I made the Moon crash into Earth, and created a Mercury for the same purpose (maybe Earth just got angry at me for this reason, and made an anti-awesomeness aura). Then I tried to create some rings, so I went into edit mode and clicked the geosync rings. Everything went fine. I changed the particle count and ring color, but when I tried 'Awesome', it stopped responding for a while and didn't add the rings. The other rings were added if I clicked them afterwards like normally, and Awesome was still shown as text in the menu.

I tried starting Universe Sandbox again, and it also happened with the normal settings (without changing them at startup).

In the engine log, it says this:
Code: [Select]
09-21-2010 18:55:58 | TEXTURE MANAGER : Couldn't find the texture 'GradientAwesome' in the texture list.
09-21-2010 18:55:58 | TEXTURE MANAGER : LockTexture : You can only lock a 2D texture
09-21-2010 18:55:58 | TEXTURE MANAGER : GetPixel : GetPixel doesn't handle the format of this texture. Use 32bits or 16bits format exclusively
09-21-2010 18:55:58 | TEXTURE MANAGER : Couldn't find the texture 'GradientAwesome' in the texture list.
09-21-2010 18:55:58 | TEXTURE MANAGER : LockTexture : You can only lock a 2D texture
09-21-2010 18:55:58 | TEXTURE MANAGER : GetPixel : GetPixel doesn't handle the format of this texture. Use 32bits or 16bits format exclusively
09-21-2010 18:55:58 | TEXTURE MANAGER : Couldn't find the texture 'GradientAwesome' in the texture list.
[And so on for 23 seconds]
« Last Edit: September 21, 2010, 10:27:08 AM by Bla »

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: Rings Don't Want to be Awesome
« Reply #1 on: October 13, 2010, 10:52:16 PM »
Thanks for reporting this. I'm going to aim to fix this in the next release.

deoxy99

  • Universe Sandbox 1 Beta Team
  • *****
  • Posts: 872
  • 💎 rad alien vibes 💎
    • It's Something
Re: Rings Don't Want to be Awesome
« Reply #2 on: October 14, 2010, 10:14:09 AM »
I can't wait for the next release!

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: Rings Don't Want to be Awesome
« Reply #3 on: October 14, 2010, 11:21:49 AM »
Is anyone else having this problem?



Bla,

It would appear that you're missing the texture file. Care to try redownloading and reinstalling the setup file?
(There's a link at the top of this page (and every page))

Let me know if that fixes it for you.

Either way, I've added some code in the upcoming version to check for the texture and abort if it's not found. That will prevent the long 23 second delay that you're experiencing now if this happens to anyone else.
« Last Edit: October 18, 2010, 09:28:08 AM by Dan Dixon »

deoxy99

  • Universe Sandbox 1 Beta Team
  • *****
  • Posts: 872
  • 💎 rad alien vibes 💎
    • It's Something
Re: Rings Don't Want to be Awesome
« Reply #4 on: October 14, 2010, 11:23:27 AM »
I don't have the problem.

Bla

  • Global Moderator
  • *****
  • Posts: 1013
  • The stars died so you can live.
Re: Rings Don't Want to be Awesome
« Reply #5 on: October 18, 2010, 12:31:40 AM »
It works after reinstalling. :)