Welcome, Guest

Author Topic: max 30FPS with decent hardware  (Read 1316 times)

Ingvarr

  • *
  • Posts: 1
max 30FPS with decent hardware
« on: January 24, 2015, 11:34:37 AM »
Hi,

I'm running a i7-4770 and an EVGA GTX 980, but for some reason, i only get a maximum of 30 FPS.
Is there any reason/ solution for this?

The Ventifact

  • *****
  • Posts: 212
  • I am the Creator...
Re: max 30FPS with decent hardware
« Reply #1 on: January 24, 2015, 08:12:15 PM »
I also have a GTX 980, but it's running higher than 30fps for me. Did you turn off vsync in the options? Look again to make sure. Oh, and look to see if your GPU is selected, sometimes it defaults to the CPU, which could explain the lower frame rate you've been seeing.

I think the option to choose your render device in under settings. I'm not quite sure, it's been awhile since I've seen the options menu. Look around, it should be in there.

EDIT: Hmm, that's weird, I thought I remember seeing something like that in the game. I guess it was either removed, or placed in a different location.
« Last Edit: January 24, 2015, 08:17:18 PM by The Ventifact »

C7

  • Development Team
  • *****
  • Posts: 544
Re: max 30FPS with decent hardware
« Reply #2 on: January 25, 2015, 09:27:07 AM »
You can change your compute device if you go into settings (little gear on the left of the screen), then select simulation and expand gravity. (You may need to click the little +), and it will show the additional information about things like the compute device. Where you can select which device to use for computation. If you don't see your processor listed as an option, you can download the OpenCL drivers for it.

Other then that, we're currently in progress on a major overhaul of our physics simulation. Once things settle down there, we can continue to press on with optimization, as there's still a lot of work to be done on that front.