Welcome, Guest

Author Topic: [BUG] Texture/Graphical Bug After Collisions.  (Read 10491 times)

newhalo123

  • ***
  • Posts: 29
[BUG] Texture/Graphical Bug After Collisions.
« on: January 15, 2015, 07:43:13 PM »
I tried searching for this issue and couldn't find it.

This happens EVERY something collides with earth.

I am not sure how to explain it, so I'll attach a couple photos of the issue, as well as the log file.

I have tried modifying setting in game, I have tried changing settings in the Nvidia Control panel, nothing helps.
I don't know what the problem is, but, it started after I upgraded to my Nvidia GTX 750. I used to have an Nvidia gt 560, and the problem never happened with that card. I do have the latest Drivers.

C7

  • Development Team
  • *****
  • Posts: 544
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #1 on: January 17, 2015, 03:36:18 AM »
I have a 700 series Nvidia card in one of my testing computers, and I've not seen anything like that. The only time I've seen similar behavior reported was from users who have overclocked their cards a bit on the aggressive side. It's possible that it's a hardware issue. Though, let's rule out the common software related issues that can cause some graphical oddness.

First thing I'd try is downloading the latest drivers from nvidia, and performing a full "clean" install.





If that doesn't solve your problem, you can also do re-install of Universe Sandbox itself with the tools in your steam account.

Option 1: (Simple re-install)
https://support.steampowered.com/kb_article.php?p_faqid=282

Option 2: (Complete re-install)
Right click on the Universe Sandbox game in your steam library, go to properties, and choose the local files tab. Click "Delete Local Game Content".

After that completes, close the window, and double click the game from your Steam library. It will ask you if you would like to download and play the game.


newhalo123

  • ***
  • Posts: 29
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #2 on: January 17, 2015, 02:08:48 PM »
I have now tried all of this and it still happens. I have not overclocked my GPU.

Also, none of my other games experience any issues whatsoever.

newhalo123

  • ***
  • Posts: 29
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #3 on: February 01, 2015, 03:32:38 PM »
An update to this. I have found that turning off displacement mapping fixes the problem. However, obviously, the collisions then don't look very great.

I am not sure what I can do to fix this issue.

C7

  • Development Team
  • *****
  • Posts: 544
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #4 on: February 03, 2015, 03:27:01 PM »
It's really odd the displacement mapping is failing, it's a pretty basic technique to offset the vertices, and I've been unable to reproduce it here.

Can you try to run the game in OpenGL mode? It will use a different renderer, and would rule out some potential sources of the problem if it works.

In your Steam Library, Right click the game, go to properties, and select the "General" tab. In there, there's a option labeled "Set Launch Options". In the text box that comes up, paste this line

-force-opengl

newhalo123

  • ***
  • Posts: 29
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #5 on: February 03, 2015, 04:51:59 PM »
That worked! I'm not getting any issues with collisions now.


C7

  • Development Team
  • *****
  • Posts: 544
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #6 on: February 03, 2015, 07:29:29 PM »
That confirms my suspicion, there's something funky going on with Unity's directX renderer and your graphics card.

It won't hurt anything to run in OpenGL mode and you should get the about the same performance. Depending on you card, OpenGL can be either a little bit faster, or a little bit slower. It's usually not even noticeable.

I'm glad it's working for you though. Mystery solved :)

Percebob

  • ****
  • Posts: 30
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #7 on: February 08, 2015, 10:28:05 AM »
Hi, I have a GTX 970 (with up to date drivers) and the same thing was happening to me while using DirectX. OpenGL fixed it.

newhalo123

  • ***
  • Posts: 29
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #8 on: June 22, 2015, 09:23:30 AM »
Sorry for the thread resurrection, but, I now cannot start the game with -force-opengl after installing Alpha 15. The game just starts as a black screen and doesn't change, no matter how long I let it sit. I even let it sit for an hour.

I removed the launch option, and the game starts fine, but I then have the same problem with displacement mapping.


C7

  • Development Team
  • *****
  • Posts: 544
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #9 on: June 22, 2015, 01:24:49 PM »
It would be really helpful if you could provide a log file of it crashing when you have OpenGL enabled. As well as the crash dump, if it produces one.

[Logs]
http://universesandbox.com/blog/2014/08/support-us2/#logs

[Crashes]
http://universesandbox.com/blog/2014/08/support-us2/#crashes
« Last Edit: June 22, 2015, 01:43:22 PM by C7 »

newhalo123

  • ***
  • Posts: 29
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #10 on: June 22, 2015, 01:55:42 PM »
It doesn't crash, so there is no crash file. Here is the output_log.txt from x64.

Also, I am unable to ex out of the application normally, so I end up having to end the process.

newhalo123

  • ***
  • Posts: 29
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #11 on: June 24, 2015, 04:33:24 PM »
Sorry for double post, but, does anyone have an update on this? I've been waiting 2 days now for a response. XD

C7

  • Development Team
  • *****
  • Posts: 544
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #12 on: June 24, 2015, 06:23:25 PM »
Sorry about the late reply, we're hard at work on a patch release.

I think it's related to a resolution bug that some users are having. We're hoping to have a patch fix release out in the next few days.

If the issue still persists we'll need new log files from you.

newhalo123

  • ***
  • Posts: 29
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #13 on: June 26, 2015, 09:08:44 PM »
Issue still happening. Here is a new log file.

newhalo123

  • ***
  • Posts: 29
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #14 on: June 28, 2015, 01:25:55 PM »
Issue still happening. Here is a new log file.
It has again been 2 days without a reply, and my latest log file has not been downloaded yet, so I assume no one has looked t it yet.

Again, sorry for the double post, but, I just wanna enjoy Universe Sandbox yo!

I'm sorry if this sounded rude, I didn't mean it that way. I know you are all probably pretty busy, so, take your time. (Just don't take too much :P )

I will also re-attach the log file.
« Last Edit: June 28, 2015, 01:30:09 PM by newhalo123 »

Jar

  • Developer
  • *****
  • Posts: 722
    • Universe Sandbox
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #15 on: June 30, 2015, 11:45:39 AM »
Sorry for the wait, newhalo123. Part of the team is taking a little break to recharge after Alpha 15. We'll be back in full force to address these issues soon.

newhalo123

  • ***
  • Posts: 29
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #16 on: July 08, 2015, 03:33:13 PM »
The team back yet? I would really enjoy being able to play the game.

C7

  • Development Team
  • *****
  • Posts: 544
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #17 on: July 09, 2015, 03:33:45 AM »
We're back from our break now. I've ran across an issue with a black screen on startup that was caused by the way our settings format has changed in the latest update.

You can clear out the settings manually, and see if that helps. But it requires a little bit of registry editing.

Go to the start menu and type regedit into the search bar. You should have an application called regedit.exe that looks like a stack of cubes.

Double click that to open in up, and on the left hand side it should have a browser for the registry keys, go to HKEY_CURRENT_USER and expand it. Inside there's a folder called Software, expand that as well, and scroll down to the folder named Giant Army, in that is another folder named Universe Sandbox, right click on the Universe Sandbox folder and select delete to remove the keys, it will ask for confirmation on removing the folder and all sub keys, just click yes there and exit the registry editor.

Fire up the game again, and it will rebuild your settings files for you.

If that's not working, I'll need to see some diagnostics from your computer, so I can hopefully isolate where the issue is coming from.

newhalo123

  • ***
  • Posts: 29
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #18 on: July 09, 2015, 12:06:24 PM »
Nope, that didn't work either. What diagnostics do you need to see?

C7

  • Development Team
  • *****
  • Posts: 544
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #19 on: July 10, 2015, 01:43:38 PM »
I'd like to see the output of the DirectX diagnostic tool. Something's pretty strange on the computer, I can see that the gpu is failing to load our shaders in the log, even though we're targeting a specification that your gpu meets.

http://windows.microsoft.com/en-us/windows-vista/run-directx-diagnostic-tool

newhalo123

  • ***
  • Posts: 29
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #20 on: July 10, 2015, 03:35:00 PM »
here is my dxdiag.

C7

  • Development Team
  • *****
  • Posts: 544
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #21 on: July 10, 2015, 04:21:33 PM »
I checked out the DXDiag, and everything seems to be in order, and functioning as expected.

What happens in the current update if you switch back to DirectX?

I did some more research into what changed, and we've upgraded Unity engine to Version 5.1. In that update they're bringing in the beta of their unified OpenGL handling, so the OpenGL renderer is actually different from previous updates.

They've added a few more command line switches in regards to OpenGL, that might help.

Try this one first,
“-force-glcore” Force best available OpenGL mode

Then, give this one a try, since it's what's explicitly defined as the Max Version for your card.
“-force-glcore44” Force OpenGL Core 4.4 mode

When you try out these OpenGL versions, it would be useful to see the log files for each attempt, and if changing the renderer makes anything different on your end.

newhalo123

  • ***
  • Posts: 29
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #22 on: July 11, 2015, 12:56:18 PM »
If I switch back to directx, the game loads fine, but then i still have the bug with the displacement mapping.

Here are the log files for -force-glcore and -force-glcore44. I will also upload logs from doing -force-opengl -force-glcore and -force-opengl -force-glcore44. I wasn't sure if I needed to use the -force-opengl or not, so I just did it with and without for glcore and glcore44.

C7

  • Development Team
  • *****
  • Posts: 544
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #23 on: July 12, 2015, 08:45:48 AM »
I checked the logs, and they appear to all be the same? I checked the event timesteps in the file, and they're identical as well.

If you could, just rename the log files to something like glcore44.txt, directx.txt, etc. so they're easy to distinguish. The game will overwrite the log files each time you start it up, so you'll need to copy them out before you start the game again with the new settings.

Did anything happen with the startup options? Any changes at all?

newhalo123

  • ***
  • Posts: 29
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #24 on: July 12, 2015, 01:56:42 PM »
Ah, sorry.

Nothing changed at all with the launch options.

Here are the logs again. I made sure to cut and paste the logs elsewhere after each start. I then named them after the launch option used.

Illusion

  • *
  • Posts: 5
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #25 on: July 12, 2015, 08:33:31 PM »
Hello, I would like to report that I have also been experiencing this same texture/graphical bug during and after collisions. I also noticed that the planet's surface near the impact site will pop in and out of the planet in a fast and glitchy fashion after the collision along with what was described by the OP. It also happens with planets other than Earth. I have an GTX 970 video card (the same card as another person who replied to this thread), and my drivers are up to date as well.

I noticed on this topic that running the game in OpenGL mode temporarily fixed the issue, and then the new update prevented OpenGL from working. Although I am not opposed to finding a solution to the OpenGL problem, I would rather the game work properly with DirectX, in case we run into driver/software problems in the future.

There must be a link between the GTX 970 and the 700 series card of the OP. This bug really ruins the experience.

C7

  • Development Team
  • *****
  • Posts: 544
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #26 on: July 14, 2015, 01:19:03 PM »
I've been testing here, and we now have team members with GTX 970 series cards. We've been able to reproduce issues with the decal shaders. It definitely is an issue specific to that card, or its drivers.

We're in the middle of rewriting our shaders to use Log-Z buffering, and we're going to attempt to fix this issue at the same time.

Ideally, this will be resolved in the next update. It's possible this might be something we can't fix though, if it really is a driver / engine issue. In that case, we'll go through and submit bug reports to the correct places.

I'll keep this post updated as we make progress on the issue.

Illusion

  • *
  • Posts: 5
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #27 on: July 16, 2015, 05:22:40 PM »
I've been testing here, and we now have team members with GTX 970 series cards. We've been able to reproduce issues with the decal shaders. It definitely is an issue specific to that card, or its drivers.

We're in the middle of rewriting our shaders to use Log-Z buffering, and we're going to attempt to fix this issue at the same time.

Ideally, this will be resolved in the next update. It's possible this might be something we can't fix though, if it really is a driver / engine issue. In that case, we'll go through and submit bug reports to the correct places.

I'll keep this post updated as we make progress on the issue.

Awesome to see you were able to reproduce the glitch. I hope you can find the fix :D! If you guys find out it's something that can't be fixed, can you help us find out how to get OpenGL to work again, since that would be a good last resort fix, but is broken at the moment (unresponsive black screen).

Thanks!

C7

  • Development Team
  • *****
  • Posts: 544
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #28 on: July 16, 2015, 05:39:02 PM »
I'm doing some tests with OpenGL to try and find out exactly what's going on, I've got a Linux and Mac machine setup to do tests, to see if I can narrow it down a bit more.

The problem there, is that Unity changed a lot of the OpenGL rendering tech they use, and it's currently listed as experimental. We've also seen OpenGL problems on Linux, when it was running fine in the past.


Illusion

  • *
  • Posts: 5
Re: [BUG] Texture/Graphical Bug After Collisions.
« Reply #29 on: July 20, 2015, 10:26:50 PM »
Any progress? Just curious because its been awhile since the last post.

Thanks