Welcome, Guest

Author Topic: [BUG] [FIXED VIA MAGIC] US2 fails to start, opens to a blank white screen...  (Read 1266 times)

Electrodynamix

  • *****
  • Posts: 77
  • Australian Alpha Tester and Astronomer
Now I have had US2 since the late alpha testing days of 8.0 and beyond, and since then I have used the program a lot without any startup issues, until now.

Wanting to start a good days videomaking, I launched the program, however it simply freezes on a white screen in window mode.  I tried leaving it for a little while, but I could tell nothing was going to happen.  I just shut it down with task manager.  I am confident there is an easy fix for this, however.  I run steam as administrator, as this fixed an earlier problem where I thought my steam account was hacked (which turned out to be true), however I still couldn't get steam to run.  I don't know if that is useful info, as US2 worked fine a few weeks ago with administrator mode.

EDIT:

I have gone through the 'how to solve startup problems' thread several times, reinstalled the game a few times, validated the game files, only to discover my computer was having a fit and somehow managed to crash.  I was honestly shocked at this point.  I did however manage to recover everything nicely, to the same old white frozen screen.

EDIT EDIT:

I found out why my computer crashed:  While re-installing the game, the files were put in the wrong directory.  Some of the old files weren't deleted (my fault) so the computer tried to launch the program from the old folder, which obviously had several trillion missing and corrupted files.

EDIT EDIT EDIT:

FIXED!

*pant pant*

As usual, a visit to my grandparents house cured the game.  Now it works fine.  I know, very strange.  The exact same issue occurs with Space Enineers, another game on steam.  I assume the white-screen glitch is caused by one of my USB hardware items.  (my mic caused clashes between software in 2011)  Therefore, taking my laptop with only limited external devices (only mouse and keyboard with charger) may actually be the fix for this bug.

I will, from now on, go to my grandparents when there is a software issue, have a barbecue, perhaps take a dip in their pool and enjoy the new, fixed US2 when I get home.
« Last Edit: January 05, 2015, 01:43:11 AM by Electrodynamix »

C7

  • Development Team
  • *****
  • Posts: 544
I'm glad it's working for you now, but that's pretty strange. There's been other users with an intermittent startup issue that fixes itself. Hopefully we can find what's causing this.