Welcome, Guest

Author Topic: My game is messed up.  (Read 1419 times)

Flamatheus

  • *
  • Posts: 2
My game is messed up.
« on: November 30, 2014, 12:20:49 PM »
So, I started Universe Sandbox 2.... however, there are no orbits (the planets and objects just flew away to outer space...) and also there is no collisions whatsoever (I spawned Jupiter to collide with the Sun, but it just went through...)

What's wrong, and how can I fix this?

Jar

  • Developer
  • *****
  • Posts: 729
    • Universe Sandbox
Re: My game is messed up.
« Reply #1 on: December 01, 2014, 01:58:06 PM »
Sorry for the trouble. It sounds like there may be an OpenCL issue, which is interfering with the physics calculations. Are your video card drivers up to date?

Please post your log file so we can see what is happening. Instructions for finding your log: http://universesandbox.com/forum/index.php/topic,12458.0.html

In the meantime, you can try running in force-CPU mode, which may help.

Force CPU Mode (turn off OpenCL)
- In Steam, Right-click on the game title under the 'Library' and select 'Properties'.
- Under the General tab click the 'Set launch options...' button.
- Enter  -forcecpu  into the launch options (note the dash) and click 'OK'.
- Close the game's 'Properties' window and launch the game.

Flamatheus

  • *
  • Posts: 2
Re: My game is messed up.
« Reply #2 on: December 01, 2014, 04:27:25 PM »
Here's my log. And yes, my video drivers are up to date

Using -cpumode makes the game SO laggy (3 fps)...