Welcome, Guest

Author Topic: Universe Sandbox is crashing on startup  (Read 28612 times)

pagalzone

  • Universe Sandbox 1 Beta Team
  • *****
  • Posts: 26
  • Dark Energy, quarks & laptons make up everything!
Universe Sandbox is crashing on startup
« on: May 01, 2010, 03:07:55 AM »
My USB Beta 5a is crashing with "safe mode" "normal mode" options. any option choosen, it exits and does not start. I have tested it on  c2d, 2gb, nvidia 8400gs and P4, 1GB, Intel 910GL graphics. what could be the reason.
« Last Edit: May 06, 2010, 09:28:48 AM by Dan Dixon »

deoxy99

  • Universe Sandbox 1 Beta Team
  • *****
  • Posts: 872
  • 💎 rad alien vibes 💎
    • It's Something
Re: Crashing USB
« Reply #1 on: May 01, 2010, 07:52:19 AM »
Something like that happened to me on Beta 3. It is now fixed for me...how could that happen if it was fixed?

atomic7732

  • Global Moderator
  • *****
  • Posts: 3834
  • caught in the river turning blue
    • Paladin of Storms
Re: Crashing USB
« Reply #2 on: May 01, 2010, 08:41:34 AM »
For one it's on a usb, maybe the USB can't take it...

Doexy, it has to be a different problem than yours.

I love computers, but I hate that there could be random errors anywhere...

Bla

  • Global Moderator
  • *****
  • Posts: 1013
  • The stars died so you can live.
Re: Crashing USB
« Reply #3 on: May 01, 2010, 09:32:22 AM »
For one it's on a usb, maybe the USB can't take it...
I think he just means Universe Sandbox. :P

atomic7732

  • Global Moderator
  • *****
  • Posts: 3834
  • caught in the river turning blue
    • Paladin of Storms
Re: Crashing USB
« Reply #4 on: May 01, 2010, 09:38:11 AM »
Oh!!!!!  ;D ;D ;D

pagalzone

  • Universe Sandbox 1 Beta Team
  • *****
  • Posts: 26
  • Dark Energy, quarks & laptons make up everything!
Re: Crashing USB
« Reply #5 on: May 05, 2010, 12:10:40 AM »
Has anybody tested on Intel 910/915 onboard graphics? its still crashing with a safe mode/normal mode window on nVidia 8400GS.

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: Crashing USB
« Reply #6 on: May 05, 2010, 09:37:36 AM »
Can you send me your log files?

And mention you're pagalzone with the crash from the forum.

You can find them here:
Documents\Universe Sandbox\Logs

Thanks!

pagalzone

  • Universe Sandbox 1 Beta Team
  • *****
  • Posts: 26
  • Dark Energy, quarks & laptons make up everything!
Re: Crashing USB
« Reply #7 on: May 06, 2010, 06:23:27 AM »
Dan
I have mailed you the log files at <email-removed-by-Dan>
pl. help me ASAP.

god bless you.
« Last Edit: May 06, 2010, 07:38:21 AM by Dan Dixon »

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: Crashing USB
« Reply #8 on: May 06, 2010, 09:28:12 AM »
Thanks for the log file. That was very interesting. It looks like your computer is missing a file. As Universe Sandbox starts up it loads code from 20-40 different libraries. For some reason it can't find one of them.

Can you re-download the latest setup file and see if that works for you? Let me know what happens either way.
http://universesandbox.com/download/

If it still crashes can you send me your log files again? We'll figure this out.


pagalzone

  • Universe Sandbox 1 Beta Team
  • *****
  • Posts: 26
  • Dark Energy, quarks & laptons make up everything!
Re: Universe Sandbox is crashing on startup
« Reply #9 on: May 06, 2010, 06:57:28 PM »
Before sending you the log files, I installed the latest version downloaded from UniverseSandbox.com a few times. Same problem appeared everytime. So, pl. treat the log files generated by the latest downloaded version 2.0.2.0.
Hope this will help you to rectify the problem. One more thing, does it support Intel 915/910 graphics? I have another machine with nVidia 8400GS.

pagalzone

  • Universe Sandbox 1 Beta Team
  • *****
  • Posts: 26
  • Dark Energy, quarks & laptons make up everything!
Re: Universe Sandbox is crashing on startup
« Reply #10 on: May 06, 2010, 10:17:38 PM »
I think the error is related to AwesomiumDotNet wrapper :

     0 | 2010-05-06 18:44:56.828 * Error: Global Crash | Could not load file or assembly 'AwesomiumDotNet, Version=1.2.0.0, Culture=neutral, PublicKeyToken=null'

Am I write?

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: Universe Sandbox is crashing on startup
« Reply #11 on: May 07, 2010, 11:12:33 AM »
I think the error is related to AwesomiumDotNet wrapper :

Yes, you are right. :)

I don't think this anything to do with your graphics driver or video card.

Here are two things to check and try:

----
(1)
Can you confirm that you have this file in the installation folder?

File:
AwesomiumDotNet.dll

Folder (probably):
C:\Program Files\Universe Sandbox

----
(2)
I give this a 25% chance of working:

From the log files, the version of .NET you have installed is maybe an early version of 2.0. Can you try installing the latest version of .NET?

http://www.microsoft.com/downloads/details.aspx?FamilyID=9cfb2d51-5ff4-4491-b0e5-b386f32c0992&displaylang=en

And let me know what happens?

Universe Sandbox only requires .NET 2, but will eventually require .NET 4 (so we can add awesome multi-core support), but this is probably a few months out.



And cheers to all those who learned English as a 2nd language. Thank you for making it easy for me to communicate with you. :)

pagalzone

  • Universe Sandbox 1 Beta Team
  • *****
  • Posts: 26
  • Dark Energy, quarks & laptons make up everything!
Re: Universe Sandbox is crashing on startup
« Reply #12 on: May 07, 2010, 08:17:48 PM »
The file AwesomiumDotNet.dll is present in the said folder. its just 72kb file dated 28/12/2009.
I have also installed .net framework 4.0 and unfortunately got same Safe/Normal mode error.
Is there any other dependency which is not confirming to required standards. Say, a dll file which is of earlier version is installed of something like that. Have you thought about a portable version so that everything can be embedded into a virtual machine without need of any supporting installations?

Regarding your English language quote, in India English is a compulsory language from class 1st. British ruled here for  50 years, therefore most of the government and private office work is also done in English along with respective regional languages of the states. there are about 23 such regional OFFICIAL languages. Most indians living in cities can read and understand basic english (if cannot speak fluently). I you have plans to tour outside US I am inviting you to visit India. I am sure it will be a memorable journey.

meanwhile problem is not solved yet.

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: Universe Sandbox is crashing on startup
« Reply #13 on: May 08, 2010, 01:48:09 PM »
That's so strange.

Thanks for testing my .NET hypothesis. Sorry that didn't work.

I've sent you an email with a program to run to further test this problem. Hopefully this will solve it.

pagalzone

  • Universe Sandbox 1 Beta Team
  • *****
  • Posts: 26
  • Dark Energy, quarks & laptons make up everything!
Re: Universe Sandbox is crashing on startup
« Reply #14 on: May 08, 2010, 05:56:05 PM »
sent you the mail with required logs.

matty406

  • *****
  • Posts: 82
Re: Universe Sandbox is crashing on startup
« Reply #15 on: May 14, 2010, 08:52:06 AM »
Unfortunately, my Sand box is acting up as well. So i'll follow this thread. :-X

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: Universe Sandbox is crashing on startup
« Reply #16 on: May 14, 2010, 03:23:29 PM »
@matty406

What's happening for you specifically?
Has it ever worked?

And can you send me your log files?

You can find them here:
(My) Documents\Universe Sandbox\Logs

matty406

  • *****
  • Posts: 82
Re: Universe Sandbox is crashing on startup
« Reply #17 on: May 14, 2010, 04:34:03 PM »
Same problem as OP, not starting in either normal or safe modes, USB 1 was working like a charm, however.

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: Universe Sandbox is crashing on startup
« Reply #18 on: May 14, 2010, 05:40:16 PM »
Thanks for the logs.

That's really strange.

Can you try restarting your computer and then running Universe Sandbox again?

Can you verify that your video drivers are up to date? (let me know if you need help with this)

matty406

  • *****
  • Posts: 82
Re: Universe Sandbox is crashing on startup
« Reply #19 on: May 15, 2010, 10:16:02 AM »
I have restarted in the past, with USB 2 installed, but to no avail.
Regarding the drivers, i have Nvidia, i'm assuming i just have to go to the update drivers page on their site? Or is there more to it?

thanks for helping, by the way. I appreciate it.  :D

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: Universe Sandbox is crashing on startup
« Reply #20 on: May 15, 2010, 10:27:19 AM »
Can you send me another log file?

- Click on the Start button
- Click Run
- Type dxdiag and press Enter
- Let this program collect info and then press "Save All Information"
- Choose a place to save the file (like your desktop) and press Ok
- Send me that file (the same method as before is fine)

Thanks. I'm consulting with the people that made the 3D engine that I'm using and this is what they've asked for to help solve your problem.

If you haven't already tried to update your drivers, just send me this log file first. And we'll try updating them later. Otherwise no worries. Either way, send me this log file.
« Last Edit: May 15, 2010, 10:59:32 AM by Dan Dixon »

pagalzone

  • Universe Sandbox 1 Beta Team
  • *****
  • Posts: 26
  • Dark Energy, quarks & laptons make up everything!
Re: Universe Sandbox is crashing on startup
« Reply #21 on: May 16, 2010, 10:09:46 PM »
my problem of Safe Mode/Normal Mode is also not yet resolved. shell i also send you the logs of DXDIAG?

matty406

  • *****
  • Posts: 82
Re: Universe Sandbox is crashing on startup
« Reply #22 on: May 24, 2010, 07:33:28 AM »
Got anything back from those guys that could be of use, Dan? It's been a while.

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: Universe Sandbox is crashing on startup
« Reply #23 on: May 24, 2010, 04:27:10 PM »
Got anything back from those guys that could be of use, Dan? It's been a while.

My apologies for not contacting you sooner. Unfortunately I have not heard from them.

Go ahead and try this as well:

my problem of Safe Mode/Normal Mode is also not yet resolved. shell i also send you the logs of DXDIAG?

I'm sorry Pagalzone for going silent. Let's try this:



For both of you:

Here's a very simple test application to run that uses the same 3D engine.

1 - Download this file:
http://universesandbox.s3.amazonaws.com/utils/UniverseSandboxEngineTest.zip
2 - Extract into a folder.
3 - Run 'EngineTest.exe'
    If it works you should see two white spheres.
4 - Either way, open and paste the contents of the Engine Test Log.txt file (it will appear in the same folder as the exe)

Thanks!


pagalzone

  • Universe Sandbox 1 Beta Team
  • *****
  • Posts: 26
  • Dark Energy, quarks & laptons make up everything!
Re: Universe Sandbox is crashing on startup
« Reply #24 on: May 24, 2010, 07:18:39 PM »
BANG!
I HAVE INSTALLED .NET FRAMEWORK 3.0 WITH SERVICE PACK 1 AND FRAMEWORK 3.5 AND IT STARTED TO WORK!
THE STARTUP ERROR "SAFE MODE" AND "NORMAL MODE" IS GONE.
DAN, PLEASE PUT A CHECK IN UPCOMING VERSIONS OF USB TO CHECK THE REQUIRED FRAMEWORKS. ALSO, I FOUND THAT USB 2 DOES NOT WORK ON WINDOWS 2000 PLATFORM AS FRAMEWORK DOES NOT GET INSTALLED ON IT.

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: Universe Sandbox is crashing on startup
« Reply #25 on: May 24, 2010, 07:50:43 PM »
Awesome. I'm so glad you figured it out. And thanks for letting me know and what you did.

Again, I'm really sorry for dropping off the radar this past week. That wasn't cool of me at all.


Based on your post I just added some code to check the .NET versions that the various dlls require:

Code: [Select]
    0 | 2010-05-24 19:42:39.642 | awesomiumdotnet.dll | v2.0.50727
     0 | 2010-05-24 19:42:39.648 | automaticupdater.dll | v2.0.50727
     0 | 2010-05-24 19:42:39.651 | ionic.zip.reduced.dll | v2.0.50727
     0 | 2010-05-24 19:42:39.653 | mtv3d65.dll | v1.1.4322
     0 | 2010-05-24 19:42:39.656 | nui.dll | v2.0.50727
     0 | 2010-05-24 19:42:39.659 | wiimotelib.dll | v2.0.50727
     0 | 2010-05-24 19:42:39.665 | update.exe | v2.0.50727
     0 | 2010-05-24 19:42:39.668 | universe sandbox.exe | v2.0.50727

It would seem that none of them need need anything greater than 2.0, but perhaps I'm missing something that's using .NET 3.5?

I wonder if somehow your .NET installation had gotten corrupted and my installing a newer version it fixed it?

That's really strange, but I'm so glad you got it fixed.

I think if you install .NET 2 on Windows 2000 it might work, but it definitely won't work if you don't have .NET installed.

matty406

  • *****
  • Posts: 82
Re: Universe Sandbox is crashing on startup
« Reply #26 on: May 25, 2010, 03:03:32 PM »
It's okay, after all, you can't concentrate on USB 24/7. :)
I'm going to try these solutions now.

matty406

  • *****
  • Posts: 82
Re: Universe Sandbox is crashing on startup
« Reply #27 on: May 25, 2010, 03:20:05 PM »
Well, i tried to install the Framework like Pagal.

apparently i don't meet requirements. lol

Here's the log for the test. That worked fine.

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: Universe Sandbox is crashing on startup
« Reply #28 on: May 25, 2010, 04:21:59 PM »
Try installing this:

http://www.microsoft.com/downloads/details.aspx?FamilyID=9cfb2d51-5ff4-4491-b0e5-b386f32c0992&displaylang=en

This is the latest version of .NET and includes support for all previous versions.

deoxy99

  • Universe Sandbox 1 Beta Team
  • *****
  • Posts: 872
  • 💎 rad alien vibes 💎
    • It's Something
Re: Universe Sandbox is crashing on startup
« Reply #29 on: May 25, 2010, 06:51:39 PM »
Well, i tried to install the Framework like Pagal.

apparently i don't meet requirements. lol

Here's the log for the test. That worked fine.
HAHAHAHAHAHAHAHA. (Not being mean, that's a bad error, and funny at the same time.)
That's a strange box, you can't install it, because you don't have it. Why?