Welcome, Guest

Author Topic: [BUG] Can't launch game without compatibility mode  (Read 1648 times)

shadow6061be

  • ****
  • Posts: 52
  • Belgian alpha tester
[BUG] Can't launch game without compatibility mode
« on: September 23, 2014, 11:12:17 AM »
Hello, so, as it is written in the title, I am unable to launch the game without using compatibility mode.
Any of the compatibility modes work (well, I tested with XP, XP SP1, XP SP2, XP SP3, Vista and even 7, although I am running on 7), so it isn't a big issue, but is still one.

I had already made a topic about this "a long time ago", but it wasn't the main subject of it and I thought I had fixed it by modifying the windows registry, which only worked once or twice (I have deleted the entry and let it rebuild itself since, allowing the game to launch in said compatibility modes).

I attached a log file of a failed launch attempt.

PS : Would it make sense that running the game in compatibility mode could slow it down, even a little ?

C7

  • Development Team
  • *****
  • Posts: 544
Re: [BUG] Can't launch game without compatibility mode
« Reply #1 on: September 23, 2014, 10:19:06 PM »
If you're able to run the game, can you do a performance test and send in your logs using the built in feedback window that shows up?

I checked your log, and it's missing all the information that I'd typically need. Which is a bit odd. But there's not any useful clues there unfortunately.

What exactly happens when you try to run without compatibility mode? Does it crash? If so, I could use the crashdump files, which are normally in the same folder as the game is installed to. There should be folders in there that are named with the date the crash happened. Inside is some more detailed engine logs and a crash dump file.

shadow6061be

  • ****
  • Posts: 52
  • Belgian alpha tester
Re: [BUG] Can't launch game without compatibility mode
« Reply #2 on: September 24, 2014, 10:06:31 AM »
When I try to run without compatibility mode, the game starts loading, up to "Finding Open CL Devices" and then I just get the window stating that UBox˛ has stopped working.

Unfortunately, I can't seem to find the crash dumps anywhere, as if they were not generated somehow.

However, I might have an additional clue.
When I tried to reproduce the crash to see exactly where it stopped, it simply didn't and launched without trouble.
The only difference here was that I was using the "Enhance 3D performance" in nVidia settings instead of my usual "activate all screens" mode (as I am using a two-way SLI of GTX660Ti).

I then tried again with my habitual "All screens" mode and it crashed again. I will now re-enable compatibility mode to do the performance test and send it to you.

Thank you for answering  :D.

C7

  • Development Team
  • *****
  • Posts: 544
Re: [BUG] Can't launch game without compatibility mode
« Reply #3 on: September 25, 2014, 01:15:19 PM »
Thanks for submitting the performance test. It seems that even in compatibility mode you're getting pretty good performance. I do notice that your SLI cards are registering as two different compute devices with different scores, which is a bit odd.

Hmm... is this happening only when you have SLI enabled, or a specific mode of SLI on? It's quite possible that compatibility mode is forcing the drivers to disable SLI.

shadow6061be

  • ****
  • Posts: 52
  • Belgian alpha tester
Re: [BUG] Can't launch game without compatibility mode
« Reply #4 on: September 25, 2014, 02:06:15 PM »
I am sorry to say that I haven't been able to reproduce a non-crahsing, non-compatibility mode launch.
I tried out every option available (Disable SLI, Enable all screens, Enable nVidia Surround end Enhance 3D performances) and restarted the computer between each try, to make sure everything was registered correctly, but I just couldn't manage to launch it again without compatibility mode...

However, as you said, I still get quite good performances in compatibility mode.

And there are still no crash dumps generated (and I am sure I am looking at the correct location, as there are a few on my laptop).

I also tried to install the game on another hard drive, with no results (unsurprisingly).

I will have to try again tomorrow, I am really sorry that I couldn't get it to launch on SLI again.

And to be more precise, when the game launched without compatibility mode, SLI was enabled.

EDIT :
I now also tried the -forcecpu option, and it didn't work either, if that helps.
« Last Edit: September 26, 2014, 12:35:22 PM by shadow6061be »