Welcome, Guest

Author Topic: Update kills performance  (Read 1325 times)

GreyGeek77

  • *
  • Posts: 1
Update kills performance
« on: September 22, 2014, 05:55:34 PM »
Running US2 on my Kubuntu 14.04 installation gave me between 30 and 60 fps.  Performance was great.   Today it was automatically updated.  Now the fps is locked at 3 or less.

I decided to see if the Windows version had the same slowdown problem.  It did not.  So, I returned to my Linux desktop and tried to rerun the game.  It would not load.  The message was "Failed to load (Missing executables)".  I followed all the suggestions and verified the files, which verified OK.   There is no option to re-install, so US2 presently does not run.

C7

  • Development Team
  • *****
  • Posts: 544
Re: Update kills performance
« Reply #1 on: September 22, 2014, 11:04:00 PM »
Sorry to hear the update is causing issues. That's really strange that it would suddenly perform worse. I suspect there's an error, or null reference occurring in your logs somewhere.

We did make changes to the build settings for Linux recently. You may need to fully uninstall the game, and re-download a clean copy from Steam.

Once it's up and running again, I'd like to take a look at your logs, and if possible. Would you run a performance test and submit it to us? You can put Attention C7 in the notes and reference this thread.

Hopefully we can find the source of this and get the game back to running smoothly for you.

Additionally, if the game is running, you can go into the settings and under the header of Gravity, there is a little plus button. If you click that it will expand down to show the compute device. Can you tell me what's listed there, and perhaps try some of the other options (if there are any), to see if they're performing better for you?

Thanks!