Welcome, Guest

Author Topic: Beta 6 bugs  (Read 3747 times)

molunbun

  • Universe Sandbox 1 Beta Team
  • *****
  • Posts: 7
Beta 6 bugs
« on: April 24, 2010, 09:27:31 PM »
1a. Strange alignment and size of the toolbox when the menu is open.
1b. If you drag the scrollbar down when the menu is open and then close the menu, you cannot see the whole thumbnails.
2. Not getting thumbnails when opening toolbox before closing the menu after startup.
3. High CPU usage even loading an empty system.
« Last Edit: April 27, 2010, 09:30:23 PM by Dan Dixon »

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3240
    • Personal Site
Re: Beta 6 bugs
« Reply #1 on: April 27, 2010, 06:58:52 PM »
Awesome. Thanks for this.

1b is fixed.

Working on 1a and 2.

3 is expected behavior. When Universe Sandbox is no longer the focused window it does lower its CPU priority from normal (what most programs are) to below normal. So while it will eat as many CPU cycles as it can get, it shouldn't get in the way of other programs.

It would appear you have a dual core machine (55% CPU usage). Once we move to .NET 4 and add good multi-core support this should be much higher than 50%.
« Last Edit: April 27, 2010, 09:30:32 PM by Dan Dixon »

deoxy99

  • Universe Sandbox 1 Beta Team
  • *****
  • Posts: 868
  • Zaraza Zaraji of the Socialist Republic of Dark Light
    • Typography Newspaper
Re: Beta 6 bugs
« Reply #2 on: April 27, 2010, 07:01:30 PM »
Awesome. Thanks for this.

1b is fixed.

Working on 1a and 2.

4 is expected behavior. When Universe Sandbox is no longer the focused window it does lower its CPU priority from normal (what most programs are) to below normal. So while it will eat as many CPU cycles as it can get, it shouldn't get in the way of other programs.

It would appear you have a dual core machine (55% CPU usage). Once we move to .NET 4 and add good multi-core support this should be much higher than 50%.
When he said 1a, 1b, 2, and 4, he meant 3 for 4.
« Last Edit: December 22, 2010, 11:55:19 AM by deoxy99 »

space guy1

  • Universe Sandbox 1 Beta Team
  • *****
  • Posts: 28
Re: Beta 6 bugs
« Reply #3 on: April 29, 2010, 09:56:07 PM »
i can't load the beta.  I have beta 5 but it says that i have the most recent version when i open it.  is there another way to open the new it?

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3240
    • Personal Site
Re: Beta 6 bugs
« Reply #4 on: April 29, 2010, 11:05:04 PM »
Yes.

But can you follow these steps first?
You're not the only one to have this problem and I'm trying to figure out what's going on so I can fix it.

(Close Universe Sandbox first if you already have it open)

1 - Open Universe Sandbox
2 - Open any system (like Our Solar System)
3 - Wait 10 seconds
4 - Open the Menu (click ... or hit ESC)
5 - Click on the "More..." link in the menu (near Tutorial)
6 - Click on "Check for Update" at the bottom of the menu
After it says "You are running the latest version"
7 - Click "Send Feedback"
8 - Type "this is space guy 1 from the forum with the update problem"
9 - Hit send.

After you do that... Try this to fix your problem:

1 - Open up the folder that contains the program. (probably C:\Program Files\Universe Sandbox\)
2 - Run "update.exe"
3 - Let me know if this updates for you.

Thanks so much.

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3240
    • Personal Site
Re: Beta 6 bugs
« Reply #5 on: April 29, 2010, 11:07:05 PM »
2. Not getting thumbnails when opening toolbox before closing the menu after startup.

Fixed. The thumbnails are no longer generated on the fly and should now load much faster too.

You can now also scroll through this list with the mouse wheel.