Welcome, Guest

Author Topic: [RETEST] Freezes on startup on Mac  (Read 1646 times)

amod

  • *
  • Posts: 2
[RETEST] Freezes on startup on Mac
« on: September 16, 2014, 07:01:52 PM »
Just purchased Universe Sandbox 2 alpha and it was looking great, but performing a little laggy. Please refer to http://universesandbox.com/forum/index.php/topic,13309.msg134331.html#msg134331.

I am having the same problem. I changed the full screen resolution and now it freezes on startup just like the above post. However, even if I wait for a long time it doesn't ever come up, I have to force kill it. I have tried reinstalling and restarting my machine with no luck. Is there somewhere in a file that I can reset the view options for this game? Thanks.
« Last Edit: September 17, 2014, 04:33:56 PM by Jar »

Jar

  • Developer
  • *****
  • Posts: 689
    • Universe Sandbox
Re: Freezes on startup on Mac
« Reply #1 on: September 17, 2014, 04:29:32 PM »
In the topic you mentioned we suggested starting in safemode through Steam.  Did you try that?

- In Steam, Right-click on the game title under the 'Library' and select 'Properties'.
- Under the General tab click the 'Set launch options...' button.
- Enter  -safemode into the launch options and click 'OK'.
- Close the game's 'Properties' window and launch the game.

This will reset all settings.

amod

  • *
  • Posts: 2
Re: [RETEST] Freezes on startup on Mac
« Reply #2 on: September 17, 2014, 09:52:08 PM »
Yes, I tried exactly that. I also tried the "-win" to try to force it to windowed mode instead of full screen. Neither switch had any affect, it doesn't look like that's working properly on the Mac.

Xriqxa

  • *****
  • Posts: 1441
  • 01000011 01101111 01101101 01101101 01110101 01101
Re: [RETEST] Freezes on startup on Mac
« Reply #3 on: September 17, 2014, 09:53:43 PM »
Idk what for, but Mac+Linux will have A-11 fixes

Jar

  • Developer
  • *****
  • Posts: 689
    • Universe Sandbox
Re: [RETEST] Freezes on startup on Mac
« Reply #4 on: September 19, 2014, 03:06:02 PM »
It's possible version 11 could have fixed this, though we weren't addressing it specifically. If it still happens, please post your log files. Instructions for finding and posting log: http://universesandbox.com/forum/index.php/topic,12458.msg125740.html#msg125740

In any case, we have a fix for the next build that will force initialize the program in windowed mode before setting it to fullscreen (or keeping it windowed, depending on settings). Combined with using safemode, this should resolve the issue.

Edit: 11.1 is available now, and supports -windowed as a launch option. This will keep your other graphics settings but override the resolution. Program startup is also forced into window mode now, so hopefully that fixes it.
« Last Edit: September 19, 2014, 06:16:20 PM by Jar »