Welcome, Guest

Author Topic: "Emit Light" not working on non-stars  (Read 4923 times)

Catscr

  • *
  • Posts: 7
"Emit Light" not working on non-stars
« on: November 29, 2013, 02:13:41 AM »
It says in one of the change logs that "emit light" should work now on any object, however I've found that it doesn't work for anything that is not a star.

I've tried big planets, small planets, even a baseball. Setting an object to "emit light" doesn't appear to do anything. When the simulation is saved, closed and then re-opened, the emit light checkbox is unchecked again even though I didn't uncheck it.

I just want a closely orbiting planet to be red hot and therefore emitting just a little light. How can I do this?
« Last Edit: December 01, 2013, 12:41:15 AM by Catscr »

gabriel.dac

  • *****
  • Posts: 517
  • Brazillian dude
Re: "Emit Light" not working on non-stars
« Reply #1 on: November 29, 2013, 10:17:57 AM »
Uhhh, planets don't emit light, son

Darvince

  • *****
  • Posts: 1837
  • 差不多
Re: "Emit Light" not working on non-stars
« Reply #2 on: November 29, 2013, 10:30:37 AM »
Now with civilization Earth emits quite a lot of light at night. Also, Io emits a lot of light at night because of its extreme volcanism. It's not unreasonable for a molten planet to be emitting light.

Catscr

  • *
  • Posts: 7
Re: "Emit Light" not working on non-stars
« Reply #3 on: November 29, 2013, 11:45:35 PM »
Yes, as I say it's a planet closely orbiting a star. I know it's not that realistic (I imagine a rocky planet hot enough to start glowing from the heat of its star would also slowly be evaporated by it) but it's a fantasy solar system I'm building.

seanjenkinsjr

  • *****
  • Posts: 98
  • proud alpha tester
Re: "Emit Light" not working on non-stars
« Reply #4 on: January 22, 2014, 05:48:17 PM »
well planets are not stars. i think all you can do is pla
y around with the settings to see if you can fix it
th
at way

Catscr

  • *
  • Posts: 7
Re: "Emit Light" not working on non-stars
« Reply #5 on: January 23, 2014, 02:55:44 AM »
Of course planets are not stars, who said they were? I've played around with every setting possible, nothing works. That's why I made this thread quite a while ago, because I had exhausted all other options in-game and found nothing online that explains it either.

This place is just so inactive. It's got a very dead feel to it. I'm quite disappointed there's nothing in ways of technical support, we're only directed to this forum for support.

Darvince

  • *****
  • Posts: 1837
  • 差不多
Re: "Emit Light" not working on non-stars
« Reply #6 on: January 27, 2014, 04:40:04 PM »
they still emit light

FiahOwl

  • *****
  • Posts: 1234
  • This is, to give a dog and in recompense desire my dog again.
Re: "Emit Light" not working on non-stars
« Reply #7 on: February 01, 2014, 06:56:24 AM »
People. . . This is a feature. Features are intended to work, no matter if they are "realistic" or not. Why isn't anyone actually helping him at all?

Catscr, you should message Dan Dixon as he will be able to help you. I apologise for the idiocy of everyone in here.

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3244
    • Personal Site
Re: "Emit Light" not working on non-stars
« Reply #8 on: February 28, 2014, 04:35:41 PM »
Features are intended to work, no matter if they are "realistic" or not.

Thanks FiahOwl.

I just tested this...
Open Earth & Moon and check "Emit light" for the moon. Works.
Then I added a teapot around the Earth, and set it to emit light. Also worked for me.

You might have to turn the slider under Emit light to make sure you can see the light.

And it's quite possible that this value isn't saved properly, but I didn't test that.