Universe Sandbox

Universe Sandbox => Universe Sandbox | Support & Bugs => Topic started by: kallisti on December 26, 2014, 11:35:00 PM

Title: Cosmetic trail settings don't stick & Rings inadjustable
Post by: kallisti on December 26, 2014, 11:35:00 PM
I apologize if this has been up befpre.

Title says most. No matter how much I tweak the trail parameters to my liking, they will reset next time I load an empty sim, or even one of my own saved ones. I have a history of "blindness", so it could very well be that I just missed a "save settings" setting somewhere.

Also, when adding rings to objects, I do not get to adjust them visually like in the old version. Nor can I increase or decrease amount of particles, etc. I believe you could adjust all that before "creating" in the old version.

Again, it could well be me who's not managed to keep up, and if so, any advise is much appreciated.

But if these issues are real, are there plans to revert the settings functionality to the more manageable level?
Title: Re: Cosmetic trail settings don't stick & Rings inadjustable
Post by: Gordon Freeman on December 27, 2014, 07:22:55 AM
Also, when adding rings to objects, I do not get to adjust them visually like in the old version. Nor can I increase or decrease amount of particles, etc. I believe you could adjust all that before "creating" in the old version.

If you hover over the ring selections a small pencil symbol will appear in the corner of the box. If you click on it a whole list of editable parameters come up. However, you cannot edit a ring after creating it, which I find very frustrating at times if I've made a mistake.
Title: Re: Cosmetic trail settings don't stick & Rings inadjustable
Post by: C7 on December 27, 2014, 12:58:28 PM
Sounds like some reasonable UI suggestions. I'll bring this up in our next meeting and see if we can figure out how complicated it would be to implement.