Welcome, Guest

Author Topic: [BUG] Vsync on Linux (Unable to resolve at this time)  (Read 1720 times)

Nell

  • *
  • Posts: 4
[BUG] Vsync on Linux (Unable to resolve at this time)
« on: August 26, 2014, 10:52:52 PM »
Vsync isn't actually working, even while the game is running fluidly at 60 FPS there's significant tearing. I think this is just the upstream Unity bug where vsync is disabled when a compositing window manager is detected. It's disappointing because all the non-Unity games I have vsync perfectly - so maybe another nudge in Unity's direction to fix vsync with composite would be helpful.

I'm running the game on Ubuntu 14.04 with an Nvidia GTX 770 and 331.38 drivers.
« Last Edit: August 28, 2014, 11:42:03 PM by C7 »

C7

  • Development Team
  • *****
  • Posts: 544
Re: Vsync on Linux
« Reply #1 on: August 27, 2014, 12:10:33 AM »
I think the Vsync issue is an engine problem. I'll do some more research and see if we've got it wrong on our end, and test some other Unity games. If not, I'll file the proper bug reports with them.

In the meantime, does this link provide any help?

http://steamcommunity.com/sharedfiles/filedetails/?id=274438424

Nell

  • *
  • Posts: 4
Re: Vsync on Linux
« Reply #2 on: August 27, 2014, 12:22:15 AM »
The log confirms that it is just the Unity bug/feature: "Compositing window manager detected - disabling vsync for performance"

At the very least it'd be nice for Unity to provide a launch option enable it despite what the autodetection thinks is best. I can't really use a different compositor with my preferred window manager (the confusingly named Ubuntu Unity). Performance is very good in games with vsync enabled on other engines, so hopefully they can fix it.

C7

  • Development Team
  • *****
  • Posts: 544
Re: Vsync on Linux
« Reply #3 on: August 27, 2014, 12:26:02 AM »
Ah right. I'll do some research to see if there's a way around it. Thanks.