Welcome, Guest

Author Topic: How to solve startup problems in the US² Alpha  (Read 14994 times)

Dan Dixon

  • Creator of Universe Sandbox
  • Developer
  • *****
  • Posts: 3243
    • Personal Site
How to solve startup problems in the US² Alpha
« on: August 23, 2014, 04:58:15 PM »
Most startup problems seem to be an issue with older hardware trying to use OpenCL (a method for doing math really fast) and failing...

Try each of these steps in turn:

1 - Force CPU Mode (turn off OpenCL)
- In Steam, Right-click on the game title under the 'Library' and select 'Properties'.
- Under the General tab click the 'Set launch options...' button.
- Enter  -forcecpu  into the launch options (note the dash) and click 'OK'.
- Close the game's 'Properties' window and launch the game.

2 - Set Graphics to Lowest Settings
- In Steam, Right-click on the game title under the 'Library' and select 'Properties'.
- Under the General tab click the 'Set launch options...' button.
- Enter  -safemode (or  -forcecpu -safemode  if you want both options on) into the launch options and click 'OK'.
- Close the game's 'Properties' window and launch the game.

---

Setting Game Launch Options on Steam
https://support.steampowered.com/kb_article.php?ref=1040-JWMT-2947

---

Other things to try:

3 - Re-installation and Verification. Sometimes a problem can be caused by an improper installation, or corrupted files from an update. To make sure your files are up to date, and intact, you can try a clean install.
- On Steam - Go to Universe Sandbox ² in your Steam Library, Right click it, and select Properties, Local Files. In there you'll find two important options:
- (Try this first) Verify Integrity of Game Cache - Verifies and re-downloads any files that are incorrect.
- (Try this if the previous option doesn't work) Delete Local Game Content - This will completely remove the installation of the game. You'll need to re-download it from your steam library once the process finishes.

4 - Temporarily shut down or disable your anti-virus software. There are some anti-virus programs that will interfere with the Unity Player. If your anti-virus has a "Game-Mode" try enabling that before you launch Universe Sandbox ².
« Last Edit: September 19, 2014, 01:06:26 PM by Dan Dixon »

WitheHole18

  • *****
  • Posts: 653
  • Nothing is created, nothing is destroyed.
Re: How to solve startup problems in the US² Alpha
« Reply #1 on: August 24, 2014, 02:08:01 AM »
Unfortunately it did not solve my problem :-\
Anyway thanks for the support.

Hyperion

  • **
  • Posts: 18
  • Oh my god, it's full of star stuff!
Re: How to solve startup problems in the US² Alpha
« Reply #2 on: August 25, 2014, 06:11:48 AM »
Not fixed even here, this game's still just a starfield panning simulator for me. I would like to run it on my Nvidia driver, not Intel HD graphics, which will surely cause me some lags since my GTX760 wasn't enough even for maxing out Universe Sandbox 1

Hyperion

  • **
  • Posts: 18
  • Oh my god, it's full of star stuff!
Re: How to solve startup problems in the US² Alpha
« Reply #3 on: August 26, 2014, 01:47:48 AM »
Newest update got it fixed, thank you!

WitheHole18

  • *****
  • Posts: 653
  • Nothing is created, nothing is destroyed.
Re: How to solve startup problems in the US² Alpha
« Reply #4 on: August 26, 2014, 04:37:03 AM »
Newest update got it fixed, thank you!
i confirme,thanks  :)

DDR2402

  • ****
  • Posts: 34
  • Polish Alpha Tester
Re: How to solve startup problems in the US² Alpha
« Reply #5 on: August 26, 2014, 03:22:15 PM »
No longer need to worry, i just replaced my amdocl.dll in C:\Windows\SysWOW64\ with amdocl.dll downloaded here: www.originaldll.com/file/amdocl.dll/8871.html.

This mean, that i'm can play Universe Sandbox 2 Alpha!!
« Last Edit: August 27, 2014, 02:52:54 AM by DDR2402 »

Jacob Norris

  • *
  • Posts: 1
Re: How to solve startup problems in the US² Alpha
« Reply #6 on: September 01, 2014, 12:26:35 PM »
I've tried both solutions and neither work. This is very frustrating. Money not well spent. I want it back if I can't get this to work. Come on now, what is the issue here?

gabriel.dac

  • *****
  • Posts: 516
  • Brazillian dude
Re: How to solve startup problems in the US² Alpha
« Reply #7 on: September 02, 2014, 12:38:04 PM »
I've tried both solutions and neither work. This is very frustrating. Money not well spent. I want it back if I can't get this to work. Come on now, what is the issue here?

I'll tell the admin about your issue

The Ventifact

  • *****
  • Posts: 212
  • I am the Creator...
Re: How to solve startup problems in the US² Alpha
« Reply #8 on: September 03, 2014, 08:33:07 AM »
I've tried both solutions and neither work. This is very frustrating. Money not well spent. I want it back if I can't get this to work. Come on now, what is the issue here?

What are your PC specs? It appears that many of the start up problems have to do with GPU's that have older versions of OpenCL. Older graphics cards have older versions of OpenCL, which might explain why it's not working for you.

If you told us what kind of graphics card you have, it might help us figure out a solution to your problem. A way to find out what is inside your computer is to use dxdiag (if you have a Windows PC that is).

Go to:

start>search bar>type dxdiag

Run the dx diagnostic, this should bring up a window, click on the "video" tab, this should list what your display driver is.


Jar

  • Developer
  • *****
  • Posts: 662
    • Universe Sandbox
Re: How to solve startup problems in the US² Alpha
« Reply #9 on: September 03, 2014, 05:59:33 PM »
I've tried both solutions and neither work. This is very frustrating. Money not well spent. I want it back if I can't get this to work. Come on now, what is the issue here?

Sorry for the startup issues.  If you're still not able to run it, please send us an email using the form on our contact page: http://universesandbox.com/contact/

We'll do our best to help you get it running, and if we can't, we'll give you a refund.


Ícaro

  • **
  • Posts: 10
Re: How to solve startup problems in the US² Alpha
« Reply #10 on: November 05, 2014, 12:57:55 PM »
neither option helped. have something else I can do?                                                                                                        ps: sorry for my bad english 

C7

  • Development Team
  • *****
  • Posts: 544
Re: How to solve startup problems in the US² Alpha
« Reply #11 on: November 06, 2014, 02:21:43 AM »
If you're still unable to start the game after trying the suggestions in this thread, please post a bug topic in this forum.

In order to help us solve the problem, we'll need you to post your error logs, or crash dump files so we can determine what's going wrong.

You can refer to this thread for more information on retrieving your error logs for Universe Sandbox.
http://universesandbox.com/forum/index.php/topic,12458.0.html

Thanks!

Ícaro

  • **
  • Posts: 10
Re: How to solve startup problems in the US² Alpha
« Reply #12 on: November 07, 2014, 03:09:40 PM »
this is the dumbest question I could make here, but how do I post my files? '-'

C7

  • Development Team
  • *****
  • Posts: 544
Re: How to solve startup problems in the US² Alpha
« Reply #13 on: November 08, 2014, 02:06:25 AM »
You can either use a file hosting service, such as drop box, to post a link to the text file. Or, when posting a reply, there's a plus sign just under where you type your messages with the label "Attachments and other options". Under the section labled "Attach", there's a box with Choose File, that lets you find the file you want to post.

Ícaro

  • **
  • Posts: 10
Re: How to solve startup problems in the US² Alpha
« Reply #14 on: November 08, 2014, 06:18:17 AM »
the only thing I found with "log" in the name is that

shadyJ

  • *
  • Posts: 8
Re: How to solve startup problems in the US² Alpha
« Reply #15 on: February 07, 2015, 07:31:51 PM »
I had the start up problem on release 13, but when I entered that '-safemode' line in the launch options, it worked. After 13.1, it doesn't work, and I can not get the program to launch at all, even trying everything on the list. What is my recourse? Will this problem be addressed in later updates? My computer isn't a weird configuration, its a pretty common build.

C7

  • Development Team
  • *****
  • Posts: 544
Re: How to solve startup problems in the US² Alpha
« Reply #16 on: February 08, 2015, 10:12:08 AM »
Can you post a new topic in the support and bugs forum, and post your logs? We've improved the logging in 13.1 and hopefully we'll be able to see exactly where it's failing now.

Additionally, if you're getting a crash, we need the crash dump files. In them meantime, till the problem is fixed, you can revert to a previous version and keep playing.

Also, if you need any further help, we can take care of it in the topic you post. I like to keep the topics in the separate threads, so others can post and find the issue if they're having the same issue.

Hopefully we'll be able to get this solved for you soon.

shadyJ

  • *
  • Posts: 8
Re: How to solve startup problems in the US² Alpha
« Reply #17 on: February 08, 2015, 12:22:47 PM »
Thank you for the response. I did some digging around and managed to get US2 working again by installing the openCL drivers from Intels website, so no worries.

C7

  • Development Team
  • *****
  • Posts: 544
Re: How to solve startup problems in the US² Alpha
« Reply #18 on: February 08, 2015, 12:43:24 PM »
Glad to hear it's working.

nidhogg

  • *
  • Posts: 1
Re: How to solve startup problems in the US² Alpha
« Reply #19 on: February 20, 2016, 07:34:33 AM »
I've only just bought it for my Mac, and I've gone through the suggestions in the original post, but I still can't open the game. It gets to the "starting sandbox" text, then the spinning disc stops moving and it closes. Any further suggestions on what to do?

Jar

  • Developer
  • *****
  • Posts: 662
    • Universe Sandbox
Re: How to solve startup problems in the US² Alpha
« Reply #20 on: February 23, 2016, 10:35:22 AM »
Sorry for the issue, nidhogg, and for the delay in our response.

You may have tried one or two of these, but please try running through these troubleshooting options for Mac: http://universesandbox.com/support/basic

Often times Mac startup issues are solved by the 4th step, disabling the Steam Overlay, but you should also try the first 3.

Let us know if that works.