Welcome, Guest

Author Topic: Orbital Period (slider) - New simulation, Screen Flashing BUG  (Read 1248 times)

Brentus

  • **
  • Posts: 12
In a new simulation, when adjusting the "Orbital Period" parameter of a planet while using the "+/- slider", each left mouse click select afterwards causes the US2 window to flash.  Additionally, after this flash behavior starts, subsequent selecting of the full screen button causes the window to flash repeatedly or like a strobe.

Steps to Create the Bug
  • Select Home -> New
  • Add a Star (In the logfile, Sun was chosen)
  • Add a Planet (In the logfile, Mars was chosen)
  • Select (planet) Edit
  • Adjust the "Orbital Period" parameter using the "+/- slider"
The screen will start flashing for each subsequent left mouse click.

After this occurs, if you select the "fullscreen" button several times (let's say 10 or so), the US2 screen starts flashing repeatedly like a strobe light. If you then select the "minimize" button while this is occurring, the US2 window will start flashing up and down making it extremely difficult to close. After killing US2 in the task manager, if you bring US2 up using the ICON, the strobe behavior continues.  If you bring it up through Steam, the strobe behavior disappears and all is back to normal.

This bug was able to be recreated on 2 different computers running Windows 8.1.  Let me know, if you need a video or additional information. 

This bug was also able to be recreated on Windows 7.  The only difference is that the only way to stop the strobe behavior is to do a complete shut down of the machine.  Even calling it up from Steam doesn't help.

« Last Edit: August 19, 2014, 10:04:13 AM by Brentus »